Reply To: No Signal (possibly related to sync issues?) – SOLVED!

NewHome Forums OSSC, OSSC Pro and DExx-vd isl OSSC – DIY Support No Signal (possibly related to sync issues?) – SOLVED! Reply To: No Signal (possibly related to sync issues?) – SOLVED!


Now it gets really weird:

Yesterday the final missing part, the IR receiver, arrived. I soldered it into place, plugged my OSSC between SNES and tv and fired it up – just for the sake of it. I didn’t expect anything… but… it worked! For the first time!!! I just had to switch to AV1… the red led lit up briefly… but then it went off and only the green led stayed on… and i enjoyed a clear an vibrant picture with sound (so the audio addon board did work too). I switched my OSSC off and on again and everything continued to work as it should. So i tried to set up the remote and therefore tested a remote from my old Toshiba crt tv for its compatibility. I pressed a button, the green led blinked… and my OSSC immediately lost sync permanently and the screen of my LG tv went black.

Since i was unable to regain a stable sync signal, i set up the remote and decided to test the firmware update via sd card. I prepared the card with the v0.77_aud *.bin file and did the update. Everything went flawlessly, so i jumped through the OSSC menu til i saw the ‘Sync options’ and played around with them. Just when i thought it couldn’t get any stranger, i chose ‘Analog sync LPF’ -> ‘Off’… and got the picture back. But just for a couple of minutes. After that, the screen stayed black again. And i couldn’t get it to work to save my life. It was frustrating.

Today i tried again… but nothing changed. The red LED always stayed on and my tv reported ‘No signal’. I switched through different output and sync settings without any success. So i did reset them, restarted my OSSC… an it worked again! I tested 50Hz and 60Hz input from my SNES… 5x scaling and the the OSSC did its job perfectly:

But after 10 minutes or so it started to loose sync briefly.

And now it’s back to the ‘no sync at all’ point… and it drives me to despair since i don’t know where to look for the culprit. Is it a cold solder joint? But i resoldered R3 and every pin on all three ICs and checked everything under a microscope for shorts. I even replaced C13 (just because i got some strange capacity readings after desoldering and testing it). Should i resolder some more parts… ALL parts?? Could it be a broken TVP1002(?) or a defective FPGA??? At least there’s no compatibility issue with my tv – cause when it works, it works like a treat. But apart from that it’s like searching for the proverbial needle in the haystack…