Have I broken my OSSC?

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #43618
    Saldali
    Participant

    Hello all

    I decided to try firmware 0.88 on my OSSC Hdmi. I had already upgraded to 0.86 before, so I was confident about 0.88.
    I downloaded de 0.88 .bin file, burnt it to a 2GB SD using Win32diskimager, used the firmware upgrade menu option.
    The upgrade went fine with no errors. In the end it told me to reset.
    I did a power cycle on the OSSC, the greeting screen showed 0.88a. The remote buttons weren’t being recognized, as it had happened with the 0.86 upgrade.

    So I reconfigured all the buttons on the remote, pressing BTN1 at power up to start the bind sequence. After that the remote was working.

    Then my troubles began:
    – The OSSC does it’s job with the standard settings, I get HDMI video output. But…
    – The OSSC always forgets the remote codes after power down; I have to repeat the key bind every time I power up.
    – Every time I try to save a profile, I get an error message “Failed -22”
    – I can’t import the profiles I generated in http://pbnl.byethost7.com – always get an error message
    – I tried to go back to fw 0.86, but now I’m getting SD Flash error after the verify
    – I tried to repeat fw 0.88, but also SD Flash error after the verify
    – I tried with 2 different SD cards.

    So now I’m stuck with a bad OSSC. Do you think the SD card reader in the OSSC went bad and corrupted the firmware?

    Hope someone in the forum can help.

    #43736
    BuckoA51
    Keymaster

    We have had some reports of clone OSSCs being incompatible with the newer firmware. If you got your OSSC from us please get in touch and I’ll check warranty.

    #43740
    Saldali
    Participant

    I got my OSSC from micomputer.es.

    The wiki at junkerhq.net lists them as source of pre assembled boards, along with others. I chose them for geographic proximity and for being in the EU.
    I thought I was getting the real deal.

    Anyway I’ve bitten the bullet and ordered a new one from you. I hope I can fix mine with a JTAG programmer and then try to sell it, to try minimize the damage.
    This is because I don’t want to be left out of the firmware improvement train.

    #43756
    megari
    Participant

    @Saldali It sucks that this happened to you – and probably many others who’ve ordered those from AliExpress or the web store you used. It is beyond anyone’s control what a random entrepreneur might do with an open hardware project like the OSSC. In this case, the web store owner does not seem to have communicated properly with the developer, and has simply added their web store to the junkerhq page. This probably led you to believe they are endorsed by the developer.

    As you’re within the EU, there should be heavy consumer protections in place, and you are likely to be eligible for an RMA. The other option for the seller is to investigate the incompatibility and contribute a fix to make the firmware work with their differently sized Flash chip.

    #43784
    Saldali
    Participant

    So, my €13 Altera USB Blaster JTAG programmer arrived.

    This was my attempt at fixing my OSSC by downgrading via JTAG, since the SD card reader went bad after the upgrade to 0.88
    I now know that my OSSC uses different parts from the one sold by VGP, which seems to account for the “accident”.

    I had previously updated from the original version (don’t know) to 0.86, and that went fine, using the SD card method.
    Since I couldn’t find 0.86 as a .jic file to get back to it, I followed the JTAG programming guide to try and download this file:
    ossc_0.85-aud.jic (EDIT: and also ossc_0.76-aud.jic)
    But then I got this error message:

    Info (209060): Started Programmer operation at Thu Dec 17 17:39:54 2020
    Info (209016): Configuring device index 1
    Info (209017): Device 1 contains JTAG ID code 0x020F20DD
    Info (209007): Configuration succeeded — 1 device(s) configured
    Error (209025): Can’t recognize silicon ID for device 1. A device’s silicon ID is different from its JTAG ID. Verify that all cables are securely connected, select a different device, or check the power on the target system. Make sure the device pins are connected and configured correctly.
    Error (209012): Operation failed
    Info (209061): Ended Programmer operation at Thu Dec 17 17:40:00 2020

    So, if anyone has an idea what’s going on, I’d very much appreciate some help. I’ve never used this tool before.

    EDIT: the OSSC was powered up when I tried this.

    #43794
    marqs
    Participant

    I generated a .jic file which has serial flash ID checks disabled. Try programming that one.

    #43795
    megari
    Participant

    @Saldali The official .jic files have been generated assuming an EPCE16 configuration device. However, the one on your OSSC is an MX25L32, which necessitates regenerating the .jic file using it. It doesn’t seem to be officially supported by Quartus Prime, but it may be possible to create a custom configuration device.

    EDIT: Pre-empted by @marqs 🙂

    #43796
    megari
    Participant

    If the file @marqs provided does not work for you, Intel’s list of supported 3rd party configuration devices may help create a suitable configuration.

    #43799
    Saldali
    Participant

    My thanks to marqs for the new file.
    I tried it, but ended up with the same error. 🙁
    megari, I took a look at the link you gave me. I understand you suggest, that I could somehow hack the code for my chip? I completely lack the skills for that 🙁

    I don’t expect marqs to support devices made with different specs from his own, but I’d be very happy – and some other people too – to at least get my device back to working condition, even with some backward firmware version that will never be upgraded again.
    …if such thing is possible.

    If I can’t go anywhere with the JTAG programmer and help from the forum, will try to invoke warranty from micomputer.es, but I suspect they’ll argue that this was my fault, for “messing up” with firmware upgrades.

    #43800
    marqs
    Participant

    Try flashing this .sof file to FPGA. If it works, update to v0.86 via SD card right after.

    #43803
    Saldali
    Participant

    Thank you marqs and all who helped, you were first class.
    I now have a working OSSC clone again.

    My new unit from VGP is on its way. The old one that’s back to working state – although stuck on fw 0.86 – I’ll try to find a buyer for it.

    I’ll be posting on the 0.88 thread, to let the other guy with same issue know about my case development.

    Thank you for a great product.
    Best regards to all

    A.Salvador

    #43889
    mr_hawk
    Participant

    thanks @Saldali, once my jtag programmer arrives I’ll follow this thread

    #43977
    mr_hawk
    Participant

    God bless you, it worked! Merry Christmas!

    Thank you @Saldali for remembering me S2.

    Oh, and @marqs I’m at your service in case you need help figuring out how to fix this compatibility issue.
    I also have a capture card, in case you need to quickly iterate testing scenarios I can share my screen on discord for example.

    Thank you very much.

    #44968
    tieelo
    Participant

    Hey!

    I have a similar problem and basically the same flash chip that doesn’t work with v0.88. Would it be able to work if I just exchanged the chip? Like soldering it onto the board instead of the other one? Just in theory.

    #44989
    BuckoA51
    Keymaster

    Only if the replacement part was pin for pin compatible with the substitute.

Viewing 15 posts - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.