OSSC not working, low current draw

NewHome Forums OSSC & OSSC Pro OSSC – DIY Support OSSC not working, low current draw

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #20620
    Aussie_John
    Participant

    I’ve encountered some issues with the kit after assembly.
    after a final inspection of the board after soldering i plumed it into a variable lab psu and applied 5v dc to the board however there was no signs of life, no green led lit and no display backlight/lext.
    the first thing i did was examine the fuses and diodes but they all checked out fine so i then started probing the power rails but all the regulators voltages going in and coming out are correct.
    the other thing is that the whole board is only drawing around 330mA of current and that seems vastly to low for what it should be, i was expecting around1.0-1.1A?
    ive also hooked up my JTAG interface and Quartus can’t even detect a device on the jtag chain so im at a loss as to what i should do next?

    #20688
    marqs
    Participant

    If power rails are OK and you can’t access FPGA via JTAG, you should check/resolder all its legs (plus the bottom ground pad). 330mA sounds normal if there’s no input – even when the active, the current draw is rarely over 0.7A.

    #21260
    Aussie_John
    Participant

    well it turns out that the fpga was dead, i ended up ordering a replacement from element14 and it worked first go after replacing it so either i got a bad fpga when i ordered the ossc kit or (and just as likely a scenario) it died somehow when i soldered it in.

    as for the JTAG interface well it still doesn’t work however im suspecting that is because its a cheap chinese clone, i’ll have to investigate that later on

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.