Tips & Tweaks: Lx3, Lx4, Lx5 modes

NewHome Forums OSSC & OSSC Pro OSSC – Discussion and support Tips & Tweaks: Lx3, Lx4, Lx5 modes

Viewing 15 posts - 1 through 15 (of 168 total)
  • Author
  • #11295

    If Lx3, Lx4 or Lx5 modes do not work on your TV set, here are some steps to try. It has been proven to work at least for me and one more user, with two different brands of TVs (Philips and Panasonic), but as usual, YMMV.
    For PAL modes, skip further down.

    First, identify supported PC modes in you TV manual. What you are looking for are:
    1024×768 (XGA)
    1280/1360/1366×768 (WXGA)
    1280×1024 (SXGA)
    1600×1200 (UXGA)
    (These are likely for 60Hz only)

    Lx3 & Lx4 (aiming for (W)XGA and SXGA resolutions, respectively)
    1. Choose the mode you are trying to get to work (Output options).
    2. Navigate to Advanced timing tweaker (Sampling options).
    3. Increase V.Active from 240 to 256. The logic here is that 3×256=768 and 4×256=1024.
    4. Decrease V.Backporch until you get an image. For my TV I had to reduce to below 7.
    5. You should now have a 720 line high image inside a 768 high frame for Lx3, and a 960 line image inside a 1024 frame for Lx4. (Or 672/896 lines with a 224 line console.)
    6. If needed, adjust H.Samplerate & H.Active to correct aspect ratio. See post by BonzoBits with example settings (Panasonic).

    For 1366 or 1360×768, try H.samplerate 1250-1320, 1020-1026.

    Lx5 mode (Generic 4:3)
    Note, This may require a UXGA compatible panel.
    Note 2, this might only work if Lx5 already works with your 263 line console, but not your 262 line console.
    1. Decrease H.Samplerate to 1950
    2. Increase H.Active to 1600 (4:3 for 1200 lines) OR decrease H.Active to 1440 (4:3 for 1080 lines).
    3. Adjust H.Sync & H.Backporch as needed.

    PAL tweaks:
    Lx3 PAL (720p50) (Generic 4:3 mode)
    1. Decrease V.Active to 240.
    2. Increase V.Backporch until you get picture (I increased to 42).

    Lx4 PAL (1080p50) (Generic 4:3 mode)
    1. Increase H. Samplerate to 2200 and H. Active to 1920.
    2. Decrease V.Active to 270.
    3. Increase V.Backporch until you get picture (approximately 28).
    NOTE: TV needs to be able to force to 4:3 aspect ratio.
    If aspect ratio still looks off, try H.Samplerate 2460, with both H.Sync and H.Backporch around 215. Source

    Alternatively, if you cannot force 4:3 you can attempt a Lx4 1440×1080 50Hz 4:3 image: increase H.Samplerate to 1900, H.Active to 1440, h.sync 150, h.backporc 212.

    Other tweaks:
    You may or may not need to:
    -switch your TV over to PC mode,
    -use an HDMI port that explicitly allows DVI input (check your TV manual),
    -change OSSC TX mode to DVI (Output Options).
    -set TV scaling option to unscaled or equivalent

    The Lx3 & Lx4 modes, if done as above and the TV does not scale it further, *should* be pixel perfect if done on a 720p or 1080p TV set, respectively. (720p TV sets are in fact usually 768p panels)

    Feel free to add any more info that worked for your case!

    Regarding external scalers, it has been reported that Lx5 works with DVDO scalers by adjusting H.Samplerate & H.Backporch as follows:
    H.SR 2057, H.BP 255 (BuckoA51, VP50Pro)
    H.SR 2040, H.BP 237 (Wildchild22, DVDO Duo) shmups forum

    Thanks to BonzoBits and Steo for contributing to this work.


    EDIT:Setting Line3x and Line4x modes to ‘320 x 240 optim’ is optional on Panasonic VT60. ‘4:3 generic’ will also give an image. Optim modes give pixels sharper edges though, so I prefer that over generic.

    Also, on the VT60 when using optim modes, I need to tweak the various h. and v. settings quite a lot in the pursuit of correct AR. Firstly the H.samplerate needs to be incremented until the picture is sharp across the whole width of the output. Next, H.backporch needs to be adjusted for some consoles, in order to centre the image.

    The final adjustment is to reduce from 256 to 240 to restore scale on the vertical.

    Also, thanks again for the tip on shmups and also for starting this thread.


    Great stuff, thanks. Still not working for my Panasonic TX-P55VT50Y, but glad some people are looking into this 🙂


    Arovane, have you established which resolutions the VT50 accepts? It was only by fluke that I learned the VT60 can accept 1024 x 768. And then also lucky that the VT60 can handle the OSSC output.

    The VT50 manual indicates that 1024 x 768 and 1280 x 768 are compatible. Need to access via Menu > picture > PC adjustments. I’m unsure if this feature is on the VT50Y as this manual is labelled with generic ‘VT50’. From personal experience my VT60A does not have certain features that the NA model has, such as the 48/60/96 hz options for 24p playback.

    Anyway, the info is on page 158.


    Wow, my tv doesn’t have half the settings that are on this manual. No PC mode either… Which make sense since my tv doesn’t have DVI input (I’m using DVI to HDMI adapter for the OSSC). That explains a lot I think. Too bad… I think I’ll have to buy a new TV someday then.



    I still think it’s worth some exploration on the TV. If you have a Framemeister handy, you can set it to output DVI signals. My TV doesn’t have a DVI input, but apparently DVI over HDMI is common and accepted by some TVs.

    I tested my TV this way and found that it accepts about half of the dozen or so DVI signals that the FM can output.

    Don’t mean to be pushy, but like you I find the PQ of Panasonic Plasmas is way ahead of most LED and LCD sets. I was hugely surprised and happy as the proverbial ‘pig in muck’ when I found I actually can use the extra OSSC modes on it.


    Yes I have a framemeister. But I’m not sure I understand what you want me to try? My OSSC is already plugged to my TV via DVI–>HDMI converter. It’s true that every system work via the framemeister… Do you mean I should route the signal to the Framemeister in DVI and then to the TV in HDMI? Would that regulate the signal? But then I would loose the advantage of the OSSC (lag free), wouldn’t I?


    Your TV supports the follow resolutions:

      Signal name    Horizontal frequency (kHz)    Vertical Frequency (Hz)
    640x480 @60Hz            31.47                         60.00
    1280X720 @60Hz           45.00                         60.00
    1920X1080 @60Hz          67.50                         60.00

    If you try to tweak the OSSC, I think you should base on this.
    Here the manual of the Panasonic TX-P55VT50Y. See page 115.
    Hope it helps.


    Here’s the step-by-step instructions. Looks like destinydoom has maybe found the answer from the manual for the VT50Y. If I were you I’d still try this FM DVI process. I’m a bit sceptical about the comprehensiveness off Panasonic user manuals, I just checked the manual for the P55VT60A (my exact model) and it doesn’t mention any of the DVI resolutions that I’ve found are compatible (1024 x 768, 1280 x 1024, etc).

    – Plug FM directly to TV or receiver (IE, not via OSSC).
    – Open the FM main menu then open DVI OUTPUT.
    -Select an output resolution and hit OK.
    – Wait a few seconds while your TV attempts to display the signal.
    – If the FM screen is displayed with a Cancel/Ok option in the bottom-left of screen, your TV is compatible. Take a note of the resolution.
    – If nothing is displayed this means your TV is not compatible with that resolution. Hitting OK again will revert to the previous resolution and display the FM menu.
    – Repeat with other DVI resolutions

    Once you’ve established which resolutions your TV accepts, you can use Harrumph’s trick to determine if it is also compatible with OSSC Lx3/4/5.


    Arovane, the problem seems to be your TV only accepts PC resolutions which conform to the HDMI standard (as also stated in a parenthesis in the manual). Unless, as bonzo says, it also accepts some “hidden” resolutions.

    Btw there is no difference between HDMI & DVI connectors/cables in terms of what video information they can carry. This is sometimes confusing due to the signal standard which is also called HDMI, which is a very limited standard (ie 480p, 720p, 1080p etc) compared to the extremely broad range of PC resolutions out there.


    Hi, thanks all for your help. I tried to tweek a little but couldn’t make Lx3/4/5 to work at all. I think as you say Harrumph that the problem is that my tv is locked with HDMI standard and nothing else come through. Marqs just told me on the shmups forum that he had the same issues with his plasma earlier generation VT30Y, so there’s that. I’ll enjoy Lx3/4/5 next time I buy a new tv 🙂 Now I’m still working on the other issues I have which is to make Nes/Snes and Neo Geo work on the VT50Y.



    I forgot to mention. After using your trick with at 256 and reducing the V.backporch to 6, the graphics coming out of the OSSC were still a bit ‘off’. Sections of the screen were fuzzy/out of focus and the in-game text (score and timers in Sonic 2) were wrong. I’d make some photos, but I’m lazy and the TV is currently being used for Netflix 🙂

    Edit: this next section is stated more clearly in a previous post.

    To fix the graphics, I used the following process:

    – increase H.samplerate until all in-game text is output sharply and fuzzy bits are eliminated (this restores the correct scale on the horizontal axis). It’s hard to describe, but the process was basically just incrementing by +1 until stuff all of a sudden just looks right. Using a screen with text on it is good because it’s easier to tell when a letter is messed up, compared to a game character or piece of scenery
    – adjust H.backporch to centre image
    – reduce from 256 to 240 (this gives the correct scale on the vertical axis)
    – correct AR is now restored and it now looks goddamn amazing

    The only issue is with my display, the image is pushed down quite a bit and ~7-10 lines of graphics at the bottom of the image are pushed below the bottom edge of the screen. It’s a small price for an amazingly crisp and vibrant image.

    Thanks again for the tip. Hopefully these extra bits will help others get the most out of their OSSC/display combo.


    Tried these tips/tweaks on my Samsung UN50KU6300FXZA but unfortunately they didn’t work in any mode, despite the TV clearly supporting these resolutions. I believe the problem might be the inability to use the TV’s PC mode with the OSSC, which is odd because my Xbox One S and PlayStation 4 are capable of using it. Maybe it’s due to the analog-to-digital signal coming from the OSSC. If anyone knows where to go from here (besides getting a new TV), please let me know!


    I tried to output DVI signal through FM, but I cannot choose a format in DVI output, they’re all grey and impossible to select, can’t even move the arrow. When I set the output on DVI anyway, I get no pictures and therefore can’t even access the menu. Have to press HDMI on the remote to get a picture.

    So yeah, seems my TV doesn’t like DVI or any PC format.


    Had a bit of an epiphany today regarding horizontal samplerates. As a result, all modes now work flawlessly! Stay tuned…

Viewing 15 posts - 1 through 15 (of 168 total)
  • You must be logged in to reply to this topic.