Reply To: JTAG flashing problems

NewHome Forums OSSC & OSSC Pro OSSC – DIY Support JTAG flashing problems Reply To: JTAG flashing problems


As far as I can see this version of Quartus Prime is just the Signal Tap Logic Analyzer, is that the equivalent of the Quartus Prime Lite Edition 17.1 I had downloaded?

It is. The installer contains Quartus SignalTap (quartus_stpw.exe) and the Quartus Programmer software (quartus_pgmw.exe). You can find the USB-Blaster drivers under the qprogrammer\drivers subfolder of your installation folder.

When it didn’t work for you – did you get the same error I did?

It happened with my first OSSC 1.5 build – so it’s been a while and i don’t remember the exact error code. I only remember trying different (newer) versions, since some versions always gave me an “Can’t access JTAG chain” error message, some resulting in a bluscreen while trying to flash the firmware and others would not recognize my USB-Blaster clone (because the included driver could not initialize properly).

I thought that it could be a problem with my system, so i tried flashing the firmware with an older PC. But since it only had Windows XP installed i had to find an even older version of the programmer software, which would run under XP. That’s why i ended up with v13.1… and it worked like a treat.
Then i thought by myself: maybe the software is the problem and not my system. So i installed v13.1 on my new system too and it also worked. After that i tried to use the older driver with a new programmer software version… but this always resulted in an error message. So i stayed with v13.1 since it worked as it should.