Reply To: OSSC red light, losing sync on Genesis/Saturn after ~10min of use

NewHome Forums OSSC, OSSC Pro and DExx-vd isl OSSC – Discussion and support OSSC red light, losing sync on Genesis/Saturn after ~10min of use Reply To: OSSC red light, losing sync on Genesis/Saturn after ~10min of use

#26185
Harrumph
Participant

Bottom line I would say is that we’re dealing with 20-30 year old consoles here. That means there are many unknowns, where odds are some consoles will just not function properly or to their original spec anymore. Add to that the variation in cabling that can be used (although quality has probably risen quite considerably in the last 5 years or so, considering the competition & standards of the two main suppliers (retrogamingcables and retro-access)).

It is true that Saturn & Genesis should work out of the gate.
What complicates your issue is that you have stable sync from your SNES. This implies that the OSSC is probably not at fault (still not certain obviously). So it’s natural to investigate the other consoles/their connections first.

I don’t think it’s fair to say that there’s “little to no support”. The creator of the OSSC replied after 1 day, the owner of VGP replied after 3 days.

From experience, I know Matt (Bucko) will happily arrange an RMA if it’s likely your OSSC is defective. Additionally, even if it doesn’t seem to be the case, he runs a “no questions asked” return policy, so you can always just return it for reinbursement (minus postage, but still).