Reply To: Dreamcast – VGA or DTV 480p confusion

NewHome Forums OSSC & OSSC Pro OSSC – Discussion and support Dreamcast – VGA or DTV 480p confusion Reply To: Dreamcast – VGA or DTV 480p confusion


I had to dig into my logs from 2012 to be able to answer your question.

Back then, I was implementing the VGA mode, and found out that the default video mode given by KOS on Dreamcast didn’t fill the full video frame. Let me explain. Just as you mention, it is 640/856 and the dreamcast can only have graphics inside those 640. However, it can fill the entire active line with a solid color. I did implement this in the suite, but as a hidden feature for my testing (Under options, select “Back to Main Menu” and press Y+A simultaneously to toggle it).

Normal Video Signal:
Full active line in white:

Under closer inspection, my monitor does have an auto adjust feature, and I can force from the menu. When the full active video area is filled with a solid color, the aspect ratio when using the auto adjust the PAR is 1:1 in 640×480. That’s why I decided to implement the 1:1 PAR linearity test for VGA when in that mode. However, if you set the whole active video area to white, you have 720×480 and the NTSC PAR.

Regular 1:1 PAR in VGA:
NTSC PAR in VGA caused by full active line in white:

This takes me to why I changed the values. The default values didn’t fill a 720×480 area when I was checking the 240p and 480i values with my scope. So I implemented a screen to test, where I could tweak the internal values for the video signal and figure out the best ones.

Main menu:
Video Test Menu:

There I noticed some values weren’t allowed, and the values I ended up with that did fill the area, didn’t crash the dreamcast and showed on the monitor were those. In other words, I messed up the timings to fit the values and didn’t notice.

I rescued that test today, and rechecked with my values combined with the proper timings, and they work. They’ll be the defaults for the suite now.

TL;DR I used those values because I made a mistake when fixing some other stuff, and they worked for me. I’m sorry for the troubled caused.

Here is a version of the suite compiled with the proper defaults for timings, and that has the Video Test debug menu enabled: