Reply To: Super Famicom Audio/Video Issues

#53170
ariyasu
Participant

Hello all again and sorry to bump an old post but I fixed the issue today and thought I would share the solution.

First I did a full system recap and the problem was still there.
Then I added 10uf decoupling capacitors to C90 to C95 as suggested in the link eatnumber1 posted above. This also did not fix the issue.

This weekend was a bank holiday so I decided to mess around with it again and see If i could get it going. A user on discord suggested I try
a different power supply, so I tried a Sega Mega Drive power brick, and the ugly vertical lines I had became ugly diagonal lines. This gave
me something new to google for and I found this post by FirebrandX
https://shmups.system11.org/viewtopic.php?f=6&t=43689&p=1312908&hilit=snes+apu+subcarrier#p1312908

My Super Famicom had a diffrent board version than the one listed in the post. Mine is SNS-CPU-RGB-01 instead of APU-01,
but I figured I would try it anyway. After lifting the leg and testing the image is crystal clear 🙂 so I am very happy
and now I am off to play though Zelda.

TL:DR Lift leg 3 of PPU-2 to fix awful RGB interferance on SNS-CPU-RGB-01 and APU-01 boards.

View post on imgur.com

  • This reply was modified 2 months ago by ariyasu.
  • This reply was modified 2 months ago by ariyasu.
  • This reply was modified 2 months ago by ariyasu.
  • This reply was modified 2 months ago by ariyasu.
  • This reply was modified 2 months ago by ariyasu. Reason: A bunch of spelling and formatting