any interlaced signals -> OSSC passthrough -> capture card = sound stutter

NewHome Forums OSSC & OSSC Pro OSSC – Discussion and support any interlaced signals -> OSSC passthrough -> capture card = sound stutter

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #41598
    criger
    Participant

    So, I’m not sure if this is an OSSC issue or if its an issue with the capture card (Elgato HD 60S).

    I’m using OBS Studio, but the problem occurs on the official Elgato software as well.
    When the OSSC receives any form of interlaced signal, if I run it in passthrough mode, the sound stutters in OBS Studio (and also in the file created).
    The sound on the TV is perfect, so the TV is interpreting the signal as it should (Or so I think…).

    However….If I run the 480i in line 2x (bob-deinterlaced) so that the signal is interpreted as 480p, then the stuttering disappears on the recording!

    So, in short, it may seem like the Elgato doesn’t like the interlaced signal from the OSSC, but it doesn’t have anything against a progressive signal from it.

    My setup:
    Note: RGB SCART cables are bought from retrogamingcables. They’re all built with CSYNC.
    Stuttering sound: Wii RGB SCART 480i / Gamecube RGB SCART 480i / PS2 RGB SCART 480i -> OSSC 1.6 (firmware 0.85) passthrough -> TV or Elgato.
    What removes stuttering: enabling bob-deinterlacing or do a passthrough on ANY progressive signal.

    Now, if I run any game on the Wii (component), Gamecube (component) or PS2 that emits a progressive signal (e.g PS1 games), the sound is OK on the Elgato.

    Does anybody know of a fix to this issue?

    Btw, I tried to run firmware 0.86, but the image was all screwed up on the OSSC. So I had to revert back to 0.85.
    And 0.86 didn’t fix the stuttering either :p

    #41603
    criger
    Participant

    A workaround to this issue (for others that might experience the same):

    Elgato doesn’t support 480i or 576i sources without some issues.
    As a workaround to this problem (in my case, this applies ONLY for footage capturing as the image on the TV will probably look crappy as hell..!):

    1. Enable line2x (bob-deinterlacing) on the OSSC to make the output be recognized as progressive instead of interlaced (but with the bobbly effect of bob-deinterlacing).

    2. In OBS Studio, right click the source –> deinterlacing –> Choose Blend or Yadif.

    This will remove a lot of the bobbly stuff with bob-deinterlacing and the captured video will much better in addition to not having any stuttering sound in the recorded video.

    I’d guess this solution would be applicable to other capture cards as well.

    #41642
    BuckoA51
    Keymaster

    Thanks for the tip, yes you should be able to do that with any bob deinterlace capture footage.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.