C64 Component Mod : Missing RED

NewHome Forums C64 & ZX Spectrum Video Enhancement C64 Component Mod : Missing RED

Tagged: , ,

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #45157
    a7mag3ddon
    Participant

    Hello,

    I got my c64 mod board back in DeC 2020 i fitted it no problems, tested it for a couple of days then put the C64 away.

    Yesterday i received a new MegaC64 switcher board so pulled out the c64 again, upon startup the screen was not the correct colours, at first i thought it must be my OSSC which it wasnt (went to rv directly) so dug out another set of cables including the small jack to RCA i had, after pulling out BLUE the screen went green, aftwr pulling out Green the screen went off after a process of elinination i worked out the RED colour was missing.

    I took the c64 apart reseated the flat cable still the same so left the c64 on whilst i googled to see if it was a problem for anyone else.

    Turned the c64 off then back on again and all colours are back as normal, even the day after the colours are normal.

    Is this a problem with the mod board or the vic or the sockets?

    Im very worried that if i pack it away again it won’t work when i try it again and then of course the mod board is almoat half a year old and harder to replace under warranty.

    I read on another post there may be a firmware update so might also try that

    Anyone have this issue before ?

    #45807
    BuckoA51
    Keymaster

    Who fitted the board for you, maybe it’s a loose connection?

    #45816
    a7mag3ddon
    Participant

    Hello,

    I fitted it, all sorted now, i needed to do the oscilator mod on my PAL board and update the firmware.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.