c64 component mod – troubleshooting

NewHome Forums C64 & ZX Spectrum Video Enhancement c64 component mod – troubleshooting

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #50254
    mwardy
    Participant

    I’ve received my c64 c0pperdragon component video mod and after a couple of months smooth sailing, I’m now having some trouble with it. It had been working GREAT, but turned the c64 on the other day and *nothing*. Using the composite video output, the c64 works fine, so the bypass side of the board is working. But nothing but a blank screen from the component output. Also, after a few moments the TV says ‘no signal’ when using the component output from the c64. Tried another tv in the house, same. Unplugged the vic adapter board and ribbon cable, re-seated to be sure, still no go. A quick check with the multimeter, the voltage regs are putting out spot on 3.3V. I’m at a bit of a loss now trying to trouble shoot. I don’t own a scope or anything. Any ideas ? Thankyou !

    • This topic was modified 1 week, 2 days ago by mwardy.
Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.