Correct settings for VGA 640×480@60 and 800×600@56?

NewHome Forums OSSC & OSSC Pro OSSC – Discussion and support Correct settings for VGA 640×480@60 and 800×600@56?

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #22259
    root42
    Participant

    I am trying to run Windows 3.11 on a Tseng ET4000, but also tried on a TVGA9000. I always see only part of the image, see both screenshot. I managed to get most of the 640×480 image with these settings (I left the 800×600 at its preset):

    H samplerate 800

    H synclen 87

    H backporch 57

    H active 640

    V synclen 2

    V backporch 33

    V active 480

    Windows 3.11 640x480@60

    Windows 3.11 800x600@56

    So how can I get the whole picture, especially for the 640×480? Since that is used also by quite a few DOS games…

    #22264
    root42
    Participant

    What I noticed when tweaking parameters is that usual infos have also front porch settings, which are missing from OSSC. Do they help in setting screen size or position?
    Would be nice to have an autoadjust or a simple H and V size and position setting… not sure what that means for implementation though.

    #22265
    Harrumph
    Participant

    Frontporches are automatically adjusted, because samplerate = active + backporch + frontporch + sync

    #22269
    root42
    Participant

    Alright, that makes sense. But why then is my picture in 640×480 cut off at the top? I tried with both Trident and Tseng VGA cards. Both have the same issue. I mean, I can’t set the V samplerate, so this is somehow implied? I think the mode shows as 525p on the OSSC, which means:

    525 = 480 + backporch + frontporch + sync

    V sync should be 2, so that leaves 43 for the porches. A backporch of 33 leaves 10 for the front. Is the frontporch the one at the top or bottom of the screen?

    #22270
    marqs
    Participant

    With V.active of 480, 480 lines should get displayed so nothing should be cropped in vertical if position is correct – are you sure overscan is disabled on your display?

    For 800×600 at 56Hz (instead of 60), you should reduce H.samplerate from 1056 to 1024 to match VESA spec.

    #22271
    root42
    Participant

    I am using a USB 3.0 capture device with OBS. I have no Overscan enabled in OBS, the capture device has no options either for that. I will attach a picture of the OSSC test screen. Maybe that helps to see if overscan is enabled…

    #22276
    paulb_nl
    Participant

    Can you post a non-scaled 640×480 capture?

    #22277
    root42
    Participant

    Sure … I think … There is an album here: https://imgur.com/a/bgNKL9P

    I will walk you through the shots:

    1. I resetted all the settings, so I have 0.81 presets. This is what 720×400 text mode looks like (both TVGA and TSENG look like this):

    720x400 preset 0.81

    2. This is OBS set to 640×480 capture (I think it only rescales the image from the USB device):

    OBS doing 640x480 capture

    3. This is 640×480 with factory defaults:

    4. This is 640×480 with 480p in sampler set to DTV:

    The DTV fix does not work in text mode though. So I think there is definitely something wrong with the OSSC’s timing.

    #22278
    paulb_nl
    Participant

    The OSSC will choose the 640×400 preset for 720×400 so you should set H.active to 720 and tweak H.backporch.

    It looks like the 640×480 capture is just shifted to the top left a bit. Tweaking H.backporch and V.backporch should shift the image. If it doesn’t then you need a new capture device.

    BTW for the sharpest capture you should always set the capture resolution to match the OSSC’s output. Then right click the capture device and change Scale filtering to point and then choose Transform->Edit transform to set the size for the maximum integer scale to fit the canvas. With 640×480 in a 1920×1080 canvas thats 1280×960. Then choose Transform->Center to Screen.

    Using LineX2 for 640×480 so the OSSC will output 1280×960 will probably be better quality than passthrough with your capture device because it is set to YUV 4:2:2.

    OBS is scaling the preview to fit the window so you should either set Preview scaling to canvas (cropped if too big) or set preview to full screen if you want to see the preview 1:1.

    #22279
    root42
    Participant

    I will try to hook the OSSC up to my TV and my PC screen. Then maybe I can see what difference the capture device makes.

    The text mode I can get to display correctly, by adjusting the backborches, yes. The 640×480 in default settings is not only shifted up and left, but on the right hand side some pixels are missing, too (note the maximize button in Windows).

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.