Dreamcast sync issues w/ firmware 0.77a

NewHome Forums OSSC, OSSC Pro and DExx-vd isl OSSC – Discussion and support Dreamcast sync issues w/ firmware 0.77a

Viewing 15 posts - 1 through 15 (of 25 total)
  • Author
  • #13966


    When I had recently updated to the latest OSSC w/ audio board upgrade firmware (0.77a), I began to have sync issues with the Dreamcast through the OSSC. I have it hooked up through VGA, going into the AV3 port on the OSSC. I am running it in RGBHV mode on an LG 55b6p TV. I set it to linemult mode 2 (3-5 are not supported, according to my unit). Games can display for a few minutes just fine, but will then start to intermittently lose sync, with the screen blinking to black on and off. This increases for a few minutes in frequency until it finally stays black for good. I was specifically testing Skies of Arcadia and Soul Calibur.

    I had no issues with 0.76a firmware, so I just flashed back to it for now. Do you think there new features added in 0.77a that are perhaps set to on by default that the Dreamcast simply doesn’t like?

    Sorry, I am a bit of a newbie to the OSSC. The Dreamcast has been the only problematic system thus far for me with the new update. All other systems work well and smooth with no sync drops.


    Are you using the recommended settings for Dreamcast as per the wiki?


    Which VGA module you are using, and is it set to VGA (480p) mode? Have you tried any other RGBHV source?


    Did you ever get to the bottom of this? I’m having the same issue.


    Just got my OSSC 1.6 and can confirm this issue is still present. Same symptoms described by the OP. Everything is perfect, then intermittent black screens and eventually no signal. I was playing Phantasy Star Online on the Dreamcast at the time for about 15 minutes before the issue presented itself. I am using the recommended DTV setting and a Kuro VGA box with a brand new VGA cable. I’ll try to reproduce the issue and see if I notice anything else. Does anyone know if there is anything I should try or anything helpful to look for?

    I just tested the same scenario (PSO on DC via VGA) and I am quite sure that the problem is in fact thermal.
    Here is the timeline of my testing:

    – 15 minutes in game –
    First loss of HDMI signal

    – 21 minutes –
    Second loss of signal event

    – 22 minutes –
    Third event, signal becomes intermittent at this point, occasionally recovering for up to a minute

    – 26 minutes –
    TV reports unsupported signal (audio stutters through for a second or two every minute or so but no picture)

    – 30 minutes –
    No change in 4 minutes, I restart the OSSC by toggling the on/off switch, the test pattern appears, I set AV3 input, everything works, a few seconds later the signal drops again, and returns intermittently

    – 32 minutes –
    Once again total loss of signal, I turn off the OSSC and leave it off for 30 seconds, once set back to AV3 the signal is back and stable

    – 35 minutes –
    Signal drops again

    – 36 minutes –
    Constant signal drops, I turn the OSSC off and leave it off for one minute

    – 37 minutes –
    Back on, signal stable

    – 40 minutes –
    First signal drop

    – 43 minutes –
    Total loss of signal, I blow onto the small copper heat-sink visible through the hole for the power switch for 15 seconds, the picture returns and is stable for several minutes

    I repeated the last procedure a few times for sanity’s sake: Wait for the signal to stop completely (not intermittently dropping) and then restore the signal simply by blowing on the heat-sink. For reference, the room was around 20 degrees Celsius.

    It seems that either my heat-sink was seated improperly at the factory or that the heat-sink itself is of insufficient size (albeit barely – the tiny amount of heat build up removed by blowing on the heat-sink shows that it is very close to being able to dissipate the necessary thermals).

    Not sure what to do about this, but hopefully this helps someone, I really don’t want to return this thing to the UK (I’m in the USA), but I also don’t really feel like installing a new heat-sink – although that seems like the best course of action at this point – assuming I can find a bigger one that will fit.


    Is everyone reporting this using 480px2 mode?


    I’m using the defaults other than setting DTV mode. My TV (Sony KDL55BX520, circa 2011) reports a 640×480 signal.


    That’s odd then, pass-through shouldn’t even be putting that much strain on the chip.


    Are you sure its the heatsink? While you are blowing air onto the OSSC you might also be cooling components around the digitizer like U4 which buffers the VGA HV sync signals.

    Do SCART or component still work when VGA stops working? If they do then its probably not an issue with the heatsink.


    A weak solder joint (affected by temperature change) is more probable cause than overheating. The digitizer chip should work fine even without heatsink (especially with line2x) – it’s more like a precaution.


    I’ve done a few hours of follow up testing:

    576p, 480p and 480i via AV2 (PS2) tested 45 mins to one hour each with no issue.
    480i and 240p signals via AV1 (PS1) for over an hour no issue.
    AV3 (Dreamcast) 480i and 240p over an hour no issue.

    While the OSSC was experiencing signal loss due to overheating using 480p on the Dreamcast via AV3 I also tried turning off the console, flipping the VGA switch to 15Khz and booting up a game with no issues after 30 minutes. Rebooting the console and flipping the VGA switch back to 480p caused the issue to return immediately. I repeated this a couple of times and found the results to be consistent.

    From what I can tell the issue is isolated to AV3 RGBHV @ 480p.


    I will give this a go on my setup once I have a 1.6 to test with.


    A minor component change was made for v1.6 board to enable more robust interlace detection on AV3 (especially DC 480i), but I doubt it’s the problem here. Could you try another 480p source via VGA to see if it inhibits similar issue?


    @marqs – I will try to get a different source to test with, though I don’t currently have another on hand

    I did some additional testing with the Dreamcast @ 480p today, letting the OSSC stay on longer and in a slightly more enclosed space (which accelerated the onset of problems). While the signal was going in and out at one point I noticed the LED flashing red quickly (it usually stays solid green, even when the signal is problematic). As this was happening the LCD began wildly switching between 525p @ 59.94Hz, 525i @ 119.88Hz and 1050i @ 59.94Hz, this lasted for about 30 seconds before the LED and LCD display stabilized back to 525p @ 59.94Hz (although the HDMI signal did not return).

    Pictures: https://imgur.com/a/jRRkY


    I’ve got a 1.6 back here from a customer and I’ve had my Dreamcast running on it for over half an hour now, no issue. We may need to RMA your unit as this definitely doesn’t seem to be normal. For the record my OSSC is on a shelf with only about an inch of ventilation above it.

Viewing 15 posts - 1 through 15 (of 25 total)
  • You must be logged in to reply to this topic.