Dreamcast Timing Weirdness on my TV

NewHome Forums OSSC, OSSC Pro and DExx-vd isl OSSC – Discussion and support Dreamcast Timing Weirdness on my TV

Tagged: , ,

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #54243
    supernintendo64
    Participant

    Hi,

    So I just got my OSSC. I needed it to plug my Dreamcast into my RCA 32LB45RQ TV because despite having VGA ports, it doesn’t support the Dreamcast’s signal. So I plug it in and set it to DTV 480p, and it looks good, except wait a minute…

    It looks like this on my TV (screenshot taken from an emulator and scaled to approximate what it looks like on the TV)

    It looks like this on my TV (screenshot taken from an emulator and scaled to approximate what it looks like on the TV)

    This is what it looks like if I run it into the TV through composite:

    The actual image is nowhere near as clear as this but again this is taken from an emulator

    (The actual image is nowhere near as clear as this but again this is taken from an emulator)

    So I set the active area to 640 and it doesn’t go as well as I hope. It interprets it as a 640×480 PC signal and this happens:

    And there's no way for the TV to blow it up without also widening it

    (Also I can’t blow it up on my TV without also widening it and it looks like crap)

    But even if I trick the TV into interpreting it as a 480p signal by playing with the other timing settings, this happens:

    I adjust the H backporch setting but so much of the right side is cut off the TV doesn’t pick up on it. So I have to fix that by turning the sample rate way down to 820. However although the picture isn’t vertically stretched anymore, the cut-off on the top and bottom is still there.

    The final result

    Here are my settings:

    H. samplerate 820
    H. s.rate frac .00
    H. Synclen 96
    H. backporch 48
    H. Active 642 (If I set it to 640 it turns into picture 3)
    V. synclen 6
    V. backporch 38
    V. active 480
    Sampling phase 180 deg

    Any tips on correcting this the best I can?

    #54246
    BuckoA51
    Keymaster

    Check your TVs settings for any overscan, just scan or similar settings to make sure it’s not applying any overscan. Your TVs handling of 640×480 is just weird, are you sure there’s no way to over ride that?

    #54252
    supernintendo64
    Participant

    It handles a GameCube over component fine. I wonder if the Dreamcast is displaying weird because it’s because it’s over HDMI.

    I found a service menu where I might be able to fix the overscan but it’s really technical.

    I’ll try another TV. I wonder if I should buy an HDMI to Component converter.

    #54259
    marqs
    Participant

    I don’t think many Gamecube games output full 480 height, it’s more like 640×448. That’s why not much gets cropped on a CRT or overscanned flat panel. DC is a bit oddball since despite not using VESA 640×480 timings, many games actually utilize 640×480 area.

    #54260
    supernintendo64
    Participant

    What about Xbox?

    #54263
    BuckoA51
    Keymaster

    Others can correct me if I’m wrong but I’m sure Xbox is 720×480 and I believe some games do use the full area.

    #54264
    supernintendo64
    Participant

    I was asking because I also have an Xbox hooked up via component and it looks fine.

    #54268
    supernintendo64
    Participant

    So I plugged it into another TV (it’s a more modern Vizio smart TV), same problem (image cut off on the top and bottom and too far to the right) but I was able to center the picture without changing the H. sample rate. Then I turned the V. Active area up a bit to 484 and it looked correct. I bought an HDMI to Component adapter from RetroRGB’s curated list, hopefully if I try transmitting the signal over component my TV will interpret the signal correctly because it won’t try to interpret the signal as a VESA signal. I can deal with whatever minor quality loss this will bring. It comes tomorrow, I’ll let you know if it works after I get it.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.