Dreamcast wrong aspect ratio

NewHome Forums OSSC & OSSC Pro OSSC – Discussion and support Dreamcast wrong aspect ratio

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #25994
    Darkwing
    Participant

    So I just reveived my OSSC and have hooked up my Dreamcast and LG 65 OLEDB7 to it. Picture quality is really nice, however I am not getting the correct aspect ratio for the DC’s 480p. I have tried two different VGA cables, same problem. The image is too narrow and the “480p in sampler” option does nothing it seems: There is no difference when going from “auto” to “DTV” to “VESA”. I have tried using 480p passthrough and 2x, same problem. I am running the VGA cable directly to the VGA input on the OSSC.

    When physically measuring the picture I get 96 cm by 79 cm which equals around 1.2 and not 1.33 as 4/3 should be.

    According to this (old) video it should work?: https://www.youtube.com/watch?v=omQ0l-RPIu4
    I always thought the C7 and B7 OLED were identical but maybe they are not.

    The Dreamcast logo at the start is running at the correct aspect ratio, but when I load the GDMenu (I have a GDEmu-DC) and/or game the picture becomes too narrow.

    Any ideas?

    #25995
    BaskinRobinson
    Participant

    I have the exact same problem: https://videogameperfection.com/forums/topic/dreamcast-ossc-toro-aspect-ratio-issue/

    Works fine on my monitor, too narrow on my TV.

    #25996
    Darkwing
    Participant

    Ok strange. Could it have something to do with the GDEMU? It just seems strange that someone with (what I used to be 100% sure was) the same TV as I can have it working.

    Shouldn’t anything happen when I adjust the “auto” to “DTV” and “VESA”?

    #25997
    Harrumph
    Participant

    Use DTV sampling, and adjust H.Active under Advanced timing from 720 to 640 (increase H.backporch until image is centered again).

    This not certain to work though, if your display ignores active area information.

    Yes, DTV and VESA should make a difference already, but again it’s sometimes up to how the display is handling it.

    #26000
    nmalinoski
    Participant

    AV3 on the OSSC is not set up by default for the DTV output of the Dreamcast and other consoles; it expects typical VGA/PC resolutions unless you enable DTV 480p (and probably also adjust the other settings described by Harrumph). It also lacks the low-pass filtering that AV1 and AV2 have that the Dreamcast’s output would benefit from. AV1 is basically already set up for the Dreamcast’s output; if you have a BeharBros Toro, the easiest fix would be to connect that to the OSSC with a male-to-male SCART cable.

    The GDEMU would have nothing to do with the video output, aside from forcing 480p for compatible games.

    #26002
    BaskinRobinson
    Participant

    I have the same narrow image on my TV using AV1 with a SCART cable as I do using AV3 with a VGA cable.

    #26020
    Steo
    Participant

    I have the same issue with my Toro but iirc the ratio is corrected when using 640×480 sampling or else just increasing H Samplerate until the screen is wide enough. Seems to work on my OLED B8.

    #26034
    Darkwing
    Participant

    Thanks, followed your advice and now it works!

    #26086
    BaskinRobinson
    Participant

    If you use 640×480 sampling, it won’t sample the entire image—only 800 pixels will be sampled instead of 858.

    #26090
    Harrumph
    Participant

    Baskin, I see in the other thread you have a Sony W6 series TV. They are kind of known to be picky with signals and how it treats them.
    I can only think of three more things to try:
    1. adjust H.Active to 704 instead of 640 (this should still look too narrow, but perhaps improve it a bit because it should be a valid signal that the TV can understand).
    2. Use horizontal zoom controls (if they exist on this TV).
    3. Increase H.Samplerate as Steo suggested. This will make the image wider, and you’ll get an oversampled rather than undersampled image. However, it’s very likely your TV wont accept it, given it’s track record…

    You are correct that 858 samplerate should be used ideally, but I’m not convinced it’s very noticeable at normal viewing distance to use 800, and for sure less distracting than an incorrect aspect ratio.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.