HDMI black level? And 480p pass through > line double?

NewHome Forums OSSC, OSSC Pro and DExx-vd isl OSSC – Discussion and support HDMI black level? And 480p pass through > line double?

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #22221

    I have a few questions about the OSSC 1.6. I’ve been playing GameCube games on my Wii connected through component to my OSSC to my Samsung ks8000 4K tv and I’ve noticed that if I use 480p line double my picture looks much worse than pass through. It IS actually sharper if I look at the pixels close up, but my TV’s upscaling seems to give a much more pleasant image. Has anyone else experienced this? I noticed that it isn’t possible to select game mode on my tv using 480p line double where I can use it for pass through. So maybe that has something to do with the quality difference?

    Also, does anyone know what HDMI black level to set the OSSC to? It seems like low looks better than full to me. Full seems overly bright and washed out? Again on 480p line double I can’t change the black level since i can’t use game mode so that could be another reason for quality difference there.


    As far as the 2x, that’s not terribly surprising. Sharper pixels don’t necessarily do the GC any favors, so the smoothed upscaling provided by your TV might look better. I am on the fence about it on my TV.

    As far as RGB range, to my knowledge it always outputs full range RGB. If your TV can display full-range RGB, then you’d want to set it to that so that the color space matches.


    Samsung sets usually default to game mode processing for PC resolutions, although you can’t choose game mode specifically, you’re still getting low lag.

    Try turning on the Allow Upsample 2x option when using 480p x 2. I have the Samsumg MU6400 and I think 480px2 looks great on it.


    I had the same problems. If full black level is too bright, adjust your brightness. Don’t change black level to low, it kills your blacktones.

    I still have the same problem with 480px2. My Samsung switches to some sort of PC mode and the picture gets much worse. Most settings are disabled and it’s impossible to get a picture as good as 480p passthrough and regular game mode. It also disables the gamemode for all the other resolutions, so I always have to turn it on again if I switch back to 480p passthrough or any other TV-resolution. Is there any way to prevent this?


    I’m just wondering about this myself. Is full range RGB the only way the OSSC works? I’m using a Vestel TV at the minute which works pretty well with the OSSC, however, there is a slight issue I’ve run into. I have to set an option named HDMI True Black to on while using the OSSC. That would be OK, except that when I use my Xbox One X on that setting, I need to set it to full RGB. Doing so just slightly impacts the darker colours, making some darker ones just about not visible. Turning the brightness up only makes blacks turn grey, so that’s not what I want at all.

    Basically the TV works perfectly for everything else using HDMI true black off and using limited RGB. Setting the HDMI true black to on is the equivalent of black level high, while off is like black level low. Because it seems to work better using the lower black and limited RGB, I’m just wondering if it’s possible to make the OSSC output the limited range instead?

    The only reason it’s even an issue is because that black setting on this particular TV affects all channels, meaning I have to toggle it between on and off whether I’m using the OSSC or another device. It’s not the end of the world having to do that, but it’d be nice to be able to toggle the RGB range on the OSSC.


    There’s a test firmware that among a potential audio Infoframe fix has YCbCr444 output option under “TX mode”. That could be useful for displays which cannot decode RGB range flag to automatically set correct range. On the downside, the conversion incurs minor banding which is easily seen in the test pattern gradient but less likely to be seen with games.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.