OSSC Help for Dejitter SNES – SHVC-CPU-01 (slight noise, green signal, jailbars)

NewHome Forums Repairs and Mods OSSC Help for Dejitter SNES – SHVC-CPU-01 (slight noise, green signal, jailbars)

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #36554
    Drakonas
    Participant

    Hello,
    I recently had a Dejitter mod installed in my SHVC-CPU-01 model SNES.

    It has light noise on edges of certain pixels. It is pretty noticeable. Here is a link to a example video: https://cdn.discordapp.com/attachments/591319044649385997/692726326700015626/20200326_092549.mp4

    Here is a picture of the Dejitter board after being installed: https://lh3.googleusercontent.com/-7xjIMPoIlcg/XnywYrvam9I/AAAAAAAAAD8/Wf1Pxek8fRUEPNCMCqWxtfZUHPSh4HiBQCK8BGAsYHg/s0/2020-03-26.jpg

    Here is a picture of the entire SNES main board after install: https://lh3.googleusercontent.com/-9YKmPlvxq0o/XnywYhFsZlI/AAAAAAAAAD4/PqsQmhtgxjA9_4TFqXVQEb0agYQrEAoQQCK8BGAsYHg/s0/2020-03-26.jpg

    Any help would be appreciated.

    I should note I have the SNES hooked using a HD Retrovision Component cable into a GCOMPSW, which is then sent to an OSSC. I have 5x enabled and working.

    To note, another issue I have is occasionally I get a green signal when I switch from 3x to 5x line mult mode (all pixels come through, but are green hued).

    I also see massive amounts of vertical jailbars on a game like Super Mario World. I may assume wrong, but I thought the dejitter might help with that. Perhaps I’m confusing it with some other de-ghosting mod.\

    EDIT: New update:

    Got a video of the green issue… and I have new issues now. 5x is jittering randomly and 3x jitters even worse. I never had 3x jitter on this TV. Sometimes it won’t even detect a signal from the OSSC at all on 3x now too. Secondly, now no audio at all comes out when I have the OSSC on 5x. I have tried upgrading the firmware from 0.84a to 0.85. I tried importing some SNES profiles and it was giving me audio cutoffs again every 5-10 seconds. I then tried resetting all OSSC settings, and now the green and 3x issues have started, along with the 5x jitter that wasn’t happening when I first got the SNES back.

    Here’s a video of 5x with the green/jitter issue: https://cdn.discordapp.com/attachments/591319044649385997/692823505250681052/20200326_155204.mp4

    • This topic was modified 7 months ago by Drakonas. Reason: Revised title to explain other issues and give more detail on my setup. Added details to body
    • This topic was modified 7 months ago by Drakonas. Reason: Update with new issues. Included new video
    #36623
    BuckoA51
    Keymaster

    Can you try another console to rule out the OSSC being faulty?

    #36629
    Drakonas
    Participant

    I tried my Dreamcast. That works fine.

    #36720
    BuckoA51
    Keymaster

    Who did the dejitter install for you was it us?

    #36725
    Drakonas
    Participant

    No, I had someone local to me install it. He is at a loss of what would cause the issue, but was willing to take a second look. However, we’re all in quarantine right now, so I am asking here to see if there may be any reason to believe this is being caused by something other than the installation. I find it odd that these problems are only occurring on the OSSC with 3x and 5x upscale, and not with a direct component feed to my HDTV. It doesn’t make sense to me why that would be due to a short circuit on the SNES itself. I have tested in a way that is logical, using the same cables and splitters, along with cutting out middleman devices (just a direct feed from SNES -> OSSC -> TV) to test if it is other devices. As far as I can tell, it’s either the OSSC or my SNES, but I don’t know which so I thought I’d ask.

    • This reply was modified 6 months, 4 weeks ago by Drakonas.
    • This reply was modified 6 months, 4 weeks ago by Drakonas. Reason: removing unnecessary info
    • This reply was modified 6 months, 4 weeks ago by Drakonas.
    #37276
    call
    Participant

    Note that the HD Retrovision cable extracts sync from composite video. The standard dejitter installation like you have only results in dejittered csync, so the sync from composite video will still have jitter.

    However, according to marqs, you may be able to work around this on your OSSC by changing the H-PLL Post-Coast sync setting to at least 2 lines.

    Source: https://shmups.system11.org/viewtopic.php?p=1324157#p1324157

    I don’t know if that will clear up all your issues, but it might help. BTW, I also have an SHVC-CPU-01 with dejitter installed, and it works well (though I normally use a csync SCART cable).

    #38227
    Jon Nielsen
    Participant

    call: Do you know if it would be safe or reasonable to bridge CSYNC to composite pin with the DeJitter installed on a SHVC-CPU-01? I’m considering sacrificing the composite video (I’d remove the relevant caps before bridging) to support both the csync scart cables and the ones which get sync from composite.

    #38397
    call
    Participant

    Jon – I believe that should work, but if you bridge the csync pin over to the composite pin, then you must also put a 330 ohm resistor between the pins. This is because the csync TTL voltage would be too high for any receiving devices expecting sync-on-composite.

    You can see here how NoAffinity connected their dejittered csync to the composite pin with a resistor:

    SNES Mini w/ Dejitter Mod

    #38405
    Jon Nielsen
    Participant

    Thanks for the info! I’ll try that.

    I already learned the hard way to add a 330ohm resistor to TTL sync doing this mod as I needed to build a SCART cable at the same time. Misunderstood what exactly was being outputted by the DeJitter board, and thought the sync was already adjusted to safe levels. Fed my OSSC with TTL sync for a few seconds making it crash – yikes 🙂

    We’ll see if routing sync to two pins will be useful. To be honest the only thing I hope to achieve is to be able to use the more expensive cable so it won’t end up in the drawer. The quality from the DeJitter’d SHVC + OSSC optimal settings is comparable to an FPGA SNES, even with the homecooked cable 😀

    #38769
    Drakonas
    Participant

    The only option I can find for a reliable CSYNC SCART cable is with a 470Ω resistor. Is that too high of a resistance? I’m not an electrician by far, so I wouldn’t know.


    @call
    The H-PLL Post Coast option DID indeed fix the super jittery signal, but the green Line5x and noise issues still persist. Also there’s a cutoff at the bottom of the screen.

    This leads me to believe that the install was done incorrectly, but I can’t see anything wrong in the photos he sent.

    I’m having him come out to revisit the issue, but any other pointers you guys have would be appreciated. Kind regards,

    Here’s a video of capture card feed showing the issues. As you can see, the fonts do NOT look correct, as the pixels are shifted left/right one pixel for some reason.

    I would upload it to a streaming service but the compression ruins the ability to see the issue.

    http://mars.whatbox.ca:42424/vid/2020-06-11%2015-15-42.mkv

    • This reply was modified 4 months, 2 weeks ago by Drakonas. Reason: Grammar
    • This reply was modified 4 months, 2 weeks ago by Drakonas. Reason: Added another question
    • This reply was modified 4 months, 2 weeks ago by Drakonas.
Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.