Help Required – Super CIC Modded 1-Chip Snes Stopped Working

NewHome Forums Repairs and Mods Help Required – Super CIC Modded 1-Chip Snes Stopped Working

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #23674
    bitoriginal
    Participant

    Hi all,

    I’ve got a Super CIC modded 1-Chip PAL SNES that I purchased from eBay about 2 years ago – I paid the guy to do the mod when I bought the console. Yesterday it stopped working.

    In case it’s useful, here’s my setup:

    Super CIC Modded PAL 1-Chip SNES
    Official PSU
    RGB Sync to Luma cable
    SD2Snes
    8bitdo Retro Receiver + Controller

    I use an SD2Snes, and yesterday I was getting a black screen when trying to play – tried manually resetting and changing region but it made no difference probably because Super CIC was enabled on the SD2Snes. I put in a PAL copy of Donkey Kong, changed the mode to 50hz and then tried the SD2Snes again, no dice. Eventually I got out my old non-modded SNES, put in the SD2Snes and disabled the Super CIC function, changed to 50hz and managed to get it work on the modded SNES. I was playing most of the evening after changing back to 60hz, everything seemed to be fine and then out of nowhere I lost video-signal. When I went to turn it back on, the power LED didn’t light up. The SD2Snes and 8bitdo receiver were both showing lights suggesting power was flowing as normal.

    For the first time, I opened up the console to have a look at the mod, and unfortunately there was lots of hot glue and some iffy looking soldering which is going to make it a pain to try and fix. I guess the hot glue was to ensure it survived in the post.

    Here’s some pictures:
    https://drive.google.com/file/d/1zMMqy9_0QxCqyc3_gSvJZDy6Zu5EjDg8/view?usp=sharing

    https://drive.google.com/file/d/1QpQvAGLYnkYiQ5xTotSE0omPQS27joLP/view?usp=sharing

    https://drive.google.com/file/d/1BnuibwBgNB-OytobKZnRCIh3INFqXJ-7/view?usp=sharing

    I also ran a SD2Snes diagnostic test which provided the below results:

    ===log opened===
    derp
    SD test… please insert card
    =============================
    data=101133b04504
    crc1 = d805a1bf crc2 = d805a1bf PASSED

    RTC Test
    ========
    setting clock to 2011-01-01 00:00:00
    2011-01-01 00:00:00
    waiting 5 seconds
    new time: 2011-01-01 00:00:05
    PASSED

    FPGA test
    =========
    configuring fpga…
    fpga_pgm: 212501 bytes programmed
    FPGA configured
    basic communication test…PASSED

    RAM test
    ========
    Testing RAM0 (128Mbit) – clearing RAM – writing RAM – verifying RAM -RAM0 PASSED

    Testing RAM1 (4Mbit) – writing RAM – verifying RAM…RAM1 PASSED

    SD DMA test
    ===========
    clearing RAM – loading test file – verifying -PASSED

    Loading SNES test ROM
    =====================

    sysclk test
    ===========
    measuring SNES clock…
    0 Hz
    0 Hz diff = 0 max = 0
    0 Hz diff = 0 max = 0
    0 Hz diff = 0 max = 0
    clock frequency out of range!
    CPUCLK: 0
    READCLK: 0
    WRITECLK: 0
    PARDCLK: 0
    PAWRCLK: 0
    REFRCLK: 0
    ROMSELCLK: 0
    FAILED

    SNES test status: IRQ: 00 PA: 00 MEM: 00/00
    Timeout! SNES appears to be dead!

    TEST SUMMARY
    ============

    flash check: 1111-4-33b04504-dfb09a7f-00-11-0
    Test Result
    —————-
    SD Passed
    USB not implemented
    RTC Passed
    CIC no run
    FPGA Passed
    RAM Passed
    SD DMA Passed
    CLK FAILED
    DAC not implemented
    SNES IRQ FAILED
    SNES RAM FAILED
    SNES PA FAILED

    So, off the back of all of this and my very limited knowledge, I’m assuming the mod has failed for any number of reason.

    I would really appreciate it if someone could point me in the right direction with trying to fix this. I’m not averse to getting the soldering iron out to try and fix the problem, although the glue may prevent that. I’ve also got a multi-meter that I don’t really know how to use but would happily take direction. I did find a Youtube video on how to check the fuse and it seems to be fine.

    #23676
    bitoriginal
    Participant

    Update – tried resoldering as many of the exposed pins as I could as they looked a bit dry.

    Did a preliminary test and so far, so good! If it was a dry joint on one the exposed pins then I feel like I’ve really lucked out.

    Apologies if my initial post wasn’t relevant to the forum – I was kinda looking for advice anywhere I could find it.

    I have asked my missus for an OSSC for Christmas though, I need those scanlines in my life, hopefully it works on my monitor and I don’t get the jitter bug.

    #24199
    BuckoA51
    Keymaster

    Entirely relevant just not always easy to find someone else to chime in on technical posts like that!

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.