x68k overscan/stretching pixels

NewHome Forums OSSC & OSSC Pro OSSC – Discussion and support x68k overscan/stretching pixels

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #22527
    Spitko
    Participant

    Hopefully a dumb/simple question, but I didn’t see anything in the wiki (Or I skimmed to quickly and missed it)

    I’m using OSSC with an x68030; it’s vertical resolutions are typically 512px, but the ossc sees 568p on the input. This is fine; the added pixels are just black anyway; but it means when we line double, we go well over the 1080p budget and lose some pixels at the bottom.

    Is there a way to just shift the image up a bit? Or some mode that would center the image instead of reading pixels from the top?

    #22528
    Spitko
    Participant

    Hah, just found it. The “Backporch” setting it seems. Though now I notice it’s seemingly not quite 1:1, as I still can’t quite fit the whole image in. Adv timing shows 640×512, so I’m not entirely sure what’s going on here.

    #22535
    paulb_nl
    Participant

    568 is the total number of lines including non-visible lines. The output resolution is 640×512(x2). You might be able to see more of the image if you increase V.active and decrease V.backporch.

    #22573
    Spitko
    Participant

    Right, I’ve done that; what I don’t get now is why the image doesn’t fit on the screen.

    640x512x2 -> 1280×1024, which should still fit inside my 1920×1080 screen.

    But it doesn’t; but about 10 pixels or so? which means we’re stretching pixels, right? There are also some stretching artfacts that can be seen in certain spots.

    How do i get it into perfect 2:1?

    #22575
    paulb_nl
    Participant

    I think you should check your displays scaling settings. It is probably overscanning.

    If you set the mask brightness to max on the OSSC and increase v.mask until you see a white line appear you can see how many pixels are missing.

    Most displays will scale the 1280×1024 image to their native resolution ex. 1080p. If you don’t want your displays to scale the image then it must have ‘Original’ or 1:1 scaling options.

    #22586
    Spitko
    Participant

    Ugh, that’s EXACTLY what’s happening, and of course this monitor lacks a “no really don’t use your own garbage scaling routine” option.

    It looks like OSSC lacks any kind of “Hey just add pixels until you hit X” option, so I guess I’ve finally got an excuse to go monitor shopping.

    Thanks for the help!

    #22589
    paulb_nl
    Participant

    Lol. I have similar issues with my Samsung monitor on the HDMI input where it will force horrible sharpening, contrast boost and overscan on 480p60, 720p60 and 1080p60 inputs.

    It does not do that on the DVI input so if you have a HDMI to DVI adapter laying around you might have a chance of at least removing overscan.

    Though my monitor forces everything to stretched full screen 16:9 on all inputs.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.