I think my OSSC is DOA

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #19889

    Connected everything and flipped the switch… nothing. Tried turning on with the remote and got the same thing.

    Connected only the power to another outlet and nothing on the screen.

    The adapter works on my gscartsw_lite and gscompsw. Also tried their power supplies on the OSSC (since it’s the same adapters) and didn’t get anything.

    Unless there’s something weird I missed, I’m assuming it’s DOA. Has anyone else had this and what was your experience?


    If I read you correctly, you tried it first with the supplied 5V adapter?
    Because the voltage rating is NOT the same as for the gscart switches. If you use one of those you risk blowing the on board fuse.


    I did use the OSSC adapter first right out of the box in another room even.


    The OSSC can only be turned on with the switch; the power button on the remote only toggles the LCD backlight.


    If you connected the Gscart PSU you may have damaged OSSC, Gscart PSU is not the same it’s higher voltage.

    Leave your OSSC 24 hours and try again hopefully it just overheated.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.