Image shifted down on TV (advanced timing settings?)

NewHome Forums OSSC, OSSC Pro and DExx-vd isl OSSC – Discussion and support Image shifted down on TV (advanced timing settings?)

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #11387

    My TV (Sony KD-55XD7005) seems to have some issues with the OSSCs HDMI output. When I set it to passthrough/1x mode, everything looks fine, but with anything from Line2x and up, the whole image is shifted downwards with a dark gray bar taking up the top space and the bottom part being cut off. On a PC monitor, everything is displayed perfectly.

    Here are some images that show the problem:

    As you can see, this happens with both 240p and 480p input.
    What’s interesting is that the amount of pixels the image is shifted down seems to be more or less random. When I switch to another mode and back to the one I had before, it usually changes.
    Sometimes, the whole image is a glitched still image, partially filled with content that the OSSC does not even output at that time, like the gray test pattern in the one image, which is probably still in the TV’s memory.

    I thought I might be able to fix this with the advanced timing settings, but I have no idea which ones I should change.


    Try V.backporch. For each step, the image should shift upwards/downwards by one line.


    I tried messing around with that, but it does not seem to change anything.

    Some questions for clarification:
    For example, I currently have a Mega Drive connected to the OSSC running in PAL mode.
    The OSSC shows RGBS 313p and runs in Line2x mode.
    This would mean I have 313×2 = 626 lines, but my TV shows a resolution of 720×576.
    Is it handling the resolution wrong or does 313p not mean it has exactly 313 lines in this case?

    Now, when I would want to change the advanced timing options, I go to Sampling opt -> select Adv. timing and select the current output resolution there, right? When I change any of the settings for 576p with the setup mentioned above, the image does not change at all.
    Also, what is the difference between the 720p and 1280×720 option in this menu?


    Some things you can try:

    -Use a different HDMI port and/or cable.
    -On your tv set HDMI signal format to Enhanced format
    -Set TV picture mode to graphics.
    -Update TV firmware.
    -Change the OSSC TX mode

    You don’t select the output resolution, you select the input resolution. If you go to Adv.timing it should already show the correct input resolution. So for the Megadrive you should select 288p for linedouble. For linetriple generic 4:3 it will show 960×288.

    The 626 lines is including non-visible lines. Standard 480p and 576p have 525 and 625 lines respectively. The difference between 720p and 1280×720 is the framerate (59.94hz vs 60hz).


    I see, thanks for the info!
    Changing the settings for 288p works. I can set the V. backporch to values between 1 and 20 without losing the image. Lower values reduce the gray bar at the top, but do not move the content itselt upwards. The space between the gray bar and the content is filled with black.

    What exactly do you mean by “enhanced format”. I can set my HDMI ports to an “optimized format” for 4k content, which unfortunately does not solve the issue. Is that what you meant?

    TV firmware (Android TV) is up to date and none of its settings I changed so far solved the problem as well as changing the OSSC TX mode to DVI.


    The green glitchy stuff I have no idea, I guess something assembly related as you have the DIY version?

    Regarding 288p material, you can also try reducing V.Active to 240, and adjust V.Backporch as needed. This made x3 mode work for PAL material on my TV (3×288 is a really weird format…).


    Setting V.Active to 240 works on one of my PC monitors, but unfortunately it does not solve the issue with the TV.
    I saw an advert for a DVDO iScan VP30 for 180€ not far from me, so I will probably get that.


    I just got the DVDO iScan VP30 and now I am almost certain that my TV’s firmware currently simply has a bug. Setting the DVDO to an output resolution of 720p or lower results in the image being distorted like this:
    Again, everything looks fine on a PC monitor. I haven’t tried to change the timing settings of the DVDO though.

    Luckily, when setting the DVDO to 1080p output, it works fine. That combined with the OSSC’s Line3x simply looks gorgeous.

    So I think we can say the Sony XD70 series (and maybe even all 2016 4k models) in the current state is not really compatible with the OSSC.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.