Intermittent flickering pixels (usually green) in x5 mode

NewHome Forums OSSC & OSSC Pro OSSC – Discussion and support Intermittent flickering pixels (usually green) in x5 mode

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #47133
    bobrocks95
    Participant

    I noticed flickering pixels on a couple systems in line x5 mode, though I haven’t done a ton of testing yet. They look very similar to what is shown in the video linked in this reddit post

    The game I’ve been testing it in most recently is Gradius Gaiden on the PS1, where green dancing pixels sometimes appear on the right side of the letters at the bottom of the screen (the gray to blue transitions at the bottom left of this pictureand seemingly other sharp color transitions. They seem to come and go based on the content on the screen, as the flickering will be on a different power-up icon square The PS1 is hooked up with a csync RGB cable with a sync stripper drawing from luma.

    I also noticed very similar dancing pixels in the 240p test suite’s color bars on Sega CD through my Genesis 2, though I believe only when set to 320×240 optimized mode and not generic. They were only on the gray/white color bars, on the right edge of just one of them around the middle, so again on the right side of a color transition from gray. I don’t think they were particularly green though. This system is also using csync RGB, and I just did a triple bypass to try and get rid of jailbars (that are still there in generic 4:3…).

    I believe both cases went away in line x4 mode.

    So things I’ve tried are:
    1) Different HDMI cable, remembering that x5 can be picky about HDMI bandwidth
    2) Different power supply
    3) Unplugging other devices from the power strip the OSSC is on

    I have a VGP-bought OSSC and I have the new menu so I’m on at least 0.87, probably 0.88 since I waited quite a while to update to the new menu.

    One thing I remember: marqs compiling alternate firmware versions for people with visual problems. No clue what those visual problems were, maybe totally unrelated!

    Sorry for the wordy post, can provide screenshots or videos and test other systems out if it’s helpful!

    • This topic was modified 2 days, 21 hours ago by bobrocks95.
    #47138
    BuckoA51
    Keymaster

    I had this exact same issue recently and it was solved by removing the right angle adapter I was using on the HDMI cable. Turns out it had some sort of “signal booster” in it, that simply caused problems.

    #47145
    bobrocks95
    Participant

    Hmm, I was using a powered HDMI splitter, which was the first thing I got rid of to make sure. But I’m straight to the TV (LG B9 OLED) now, and tried with different cables, including my nice HDMI 2.1 certified one that works with my PC at 4K 120Hz 10 bit color, so absolutely overkill.

    #47178
    bobrocks95
    Participant

    I finally tracked down some old shmups posts about the alternative firmware- it was related to fitter seeds used at compile time.

    https://shmups.system11.org/viewtopic.php?p=1378441#p1378441

    Those small flickering pixels are the kind of thing I’m seeing- not awful or anything, but definitely annoying when they crop up.

    Marqs, would it be possible to recompile the latest firmware with an alternate seed if that’s easy enough to do? Maybe it’s a crapshoot and I’m misunderstanding though. In the meantime I will try some older firmware versions and see if I can get one that works better.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.