Issue with Magewell HDMI USB after Firmware update

NewHome Forums CPS2 digital AV interface Issue with Magewell HDMI USB after Firmware update

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #38234
    Velyks
    Participant

    Hi,

    I’ve updated my CPS2 Digi AV to the latest cps2_digiav.jic off of github and now my capture card doesn’t want to see it, changing resolution doesn’t fix it either. I’ve tried downgrading the firmware back to multiple versions available in the github history but none of them seem to make it work. It was previously working with the stock firmware it came with (Bought oct 2019).

    Capture card is a Magewell USB Capture HDMI (Gen2)

    The CPS2 digi av seems to work with some of my PC monitors and not with others, it works with my LG TV too. I’ve tried replacements for everything in between.

    Do you have any ideas as to how I could debug this?

    Thanks.

    • This topic was modified 2 months, 1 week ago by Velyks.
    #38262
    marqs
    Participant

    The “stock” firmware is this one. Which PC monitors do not work with the board (any fw)? Refresh rate (59.64Hz) should be the only thing that potentially limits compatibility, otherwise most output modes follow standard timings.

    #38287
    Velyks
    Participant

    Sorry for the wait, I was waiting to pick up my OSSC from my friends so I could test that too.

    The PC monitor that doesn’t work is the Dell S2417DG, the monitor that works is the Dell U2415.

    I’ve just checked it with my OSSC (0.83a) capturing from my CPS2 supergun at x5line 1920×1200 and it seems to handle that fine, the FPS being seen as 59.66fps.

    My capture card is seeing the OSSC 5xline 1920×1200 timings as:
    Frame rate – 59.66 Hz
    H Total – 2046 px
    H Active – 1920 px
    H fp – 54 px
    H sw – 30 px
    H bp – 42 px
    V Total – 1310 lines
    V active – 1200 lines
    V fp – 20 lines
    V sw – 15 lines
    V bp – 75 lines

    Edit: I’ve reverted back to the firmware you linked but it’s still no good 🙁

    • This reply was modified 2 months, 1 week ago by Velyks.
    #38460
    marqs
    Participant

    It sounds something on the board has got broken if it no more gets detected by capture card it worked with earlier. S2417DG accepting 59.6Hz from OSSC but not from cps2_digiav is also pointing that there’s a problem with the hardware – did you try this monitor when the board was still working with the capture card? One potential reason could be either TMDS clock +/- connection issue between ADV7513 and HDMI connector.

    #38461
    Velyks
    Participant

    Thanks for getting back.

    No I didn’t. I’ve only tried it with several monitors after I found it no longer worked with the Magewell. I’ve since bought a cheap chinese USB3 HDMI capture card (The one in a blue anodized aluminium enclosure) that works with the cps2 hdmi with latest firmware but I can’t pull any diagnostic information out of it. I’d still like to get it working with my original one again as that cost an order of magnitude more and is far more capable.

    I do have a scope (Rigol 1054z, 100Mhz) and I can try and get some readings if you’re able to tell me which pins to poke to see if the clocks are fine.

    Is the CPS2 hdmi able to handle the kind of dodgy 5v’s you see in cabs? I’m wondering if having it in a cab where the 5v line could have been set to 5.5v or such could damage this.

    #38475
    marqs
    Participant

    If you have HDMI-DVI cable, you should be able to easily probe TMDS pins to see if some of them has very different signal compared to rest. Alternatively, you can just use a multimeter connectivity check (with everything turned off) to ensure connectivity between TMDS pins on the connector and respecive legs on ADV7513. 5V line mainly goes to regulators which should be able to tolerate 5.5V (but not much more).

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.