LG BX OLED gets intermittent static image with OSSC

NewHome Forums OSSC, OSSC Pro and DExx-vd isl OSSC – Discussion and support LG BX OLED gets intermittent static image with OSSC

Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • #45406
    MasoElCaveman
    Participant

    This issue normally doesn’t happen often, but I’ve noticed when playing 4×4 Evolution on my Dreamcast through the Kuro vga box, my screen gets this random static over my whole image for a split second.

    The weird thing is, is that when I switch to 1st person view it basically never happens. But when in 3rd person it happens almost once every 20 seconds or more and is very distracting. When in 3rd person in this game the frames do get lower; so it runs at a higher fps more consistently when in 1st.

    Here’s it in action

    Any thoughts?

    Edit: This isn’t the OSSC. I just viewed some wallpapers on wallpaper engine through my pc using a different hdmi, and some of those made by display do that exact same thing. Mostly fast moving bright content makes it happen, what’s this mean for my tv? Bad hdmi cables or bad panel?

    #45419
    BuckoA51
    Keymaster

    I would definitely start with changing the HDMI cable. Any switches/splitters etc in the chain?

    #45426
    MasoElCaveman
    Participant

    No switches or splitters, just going straight hdmi from ossc to my display. I’ve now tried 4 different hdmi cables, but none of them have the orange certified hdmi.org label as my run is ~30ft and I can’t find any certified ones local for that length.

    Looks like I gotta pay a little more and try finding a certified high speed hdmi from online to test.

    #45506
    BuckoA51
    Keymaster

    Have you checked see if Blue Jeans Cable sell a certified cable that long? I think they do.

    Can’t hook up a shorter cable just temporarily to test?

    #45508
    Harrumph
    Participant

    Maybe try a repeater/booster?

    #45517
    MasoElCaveman
    Participant

    I just received a 30ft certified monoprice cable and same result. I guess the next thing for me to do is move my whole setup so I can try a shorter cable on my tv. That’s going to take some time hopping up on my table and moving the Dreamcast, Kuro, and OSSC into a temporary position, but I need to know if I can get it to stop.

    #45518
    MasoElCaveman
    Participant

    Before moving my setup I tried it on my old pc display and no glitching there.

    Just moved the Dreamcast closer to the tv and tried 2 other short hdmi cables and SAME GLITCHY RESULTS! It has to be something in my tv… not cool.

    #45519
    MasoElCaveman
    Participant

    Just captured an interesting screen shot. Only the hdmi source itself is getting the static.

    https://ibb.co/r3tV1z6

    Hmmmm…

    #45529
    BuckoA51
    Keymaster

    You mean you’re only getting the static on HDMI 4 and that’s the only one with deep colour off? Deep colour shouldn’t make a difference for OSSC.

    #45530
    MasoElCaveman
    Participant

    No all the hdmi sources are getting it no matter the setting. That last picture just proves that it isn’t my whole panel glitching as the built in tv settings menu doesn’t get affected during the glitch

    #45533
    BuckoA51
    Keymaster

    Ok, but definitely try disabling deep colour on the input if you haven’t already.

    If every input is doing that regardless of source or cable then you may have a faulty panel.

    #47103
    Josue Castaner
    Participant

    Heyyy my LG BX does the same thing! I thought it was my koryuu as I haven’t noticed it with just the OSSC. My setup consist of an Otaku SCART switch that goes to the OSSC and the HDMI from OSSC to HDMI switch and then to the TV. I use cables from RetroGamingCables and short HDMI cables. Here’s a picture of the issue!

    https://ibb.co/nPJYXxG

    #48643
    MasoElCaveman
    Participant

    Well today I just got my OLED panel replaced as well as a new mainboard for my LG BX. Unfortunately there is no change to my issue here.

    Even with the new panel and board my display still has the exact same screen glitching that only appears on certain games and somewhat specific scenes; so at this point I can safely rule out bad hdmi cables, bad panel, and a bad main board.

    There’s gotta be some setting I can change to fix this, maybe sync settings on the OSSC could play a part?

    Or perhaps the LG BX just glitches during very specific scenarios and there’s nothing that can really be done?

    #48661
    BuckoA51
    Keymaster

    Do you have the input the OSSC is connected to set to PC mode? Go to the home dashboard and change the icon for the input to PC, see if that makes any difference.

    Turn off any and all picture processing (though game mode should turn those off anyway).

    #48665
    MasoElCaveman
    Participant

    Appreciate the response. I have the input changed to pc mode, all AI settings are off, no picture processing is on, hdmi deep color is off, instant game response is off. Even tried disabling all power saving and burn in reduction settings, but nothing seems to stop the screen flashing in any games that are really prone to making it happen.

    Thankfully only 4×4 Evolution is actually unplayable because of it, but Bully on the PS2 also does it quite a bit.

Viewing 15 posts - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.