Mi OSSC stopped working

NewHome Forums OSSC & OSSC Pro OSSC – Discussion and support Mi OSSC stopped working

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #21455
    PRC
    Participant

    Hello,

    I’ve been using the OSSC for a few months and it has worked great (2x, 3x, 4x and 5x working). But today I tried to play with my snes (same as last night) and it didn’t work… Here are the symptoms:

    – Yesterday I updated the firmware to the 0.81 version (I have a 1.6 OSSC) and played for around 2 hours just fine.
    – Today everything was plugged exactly the same as last night (same rgb cable, same tv, same snes, same game, etc).
    – Turned the OSSC, selected av1 RGBs and turn the snes on.
    – A noise came from the tv, like static. The ossc screen showed a bunch of numbers and the sync came on and off.
    – I was able to get a stable sync after a while (audio noise was worst with sync), but the image had a lot of video noise (all the modes worked, but all with noise).
    – After that, sync was lost and I can’t get it back.
    – Tried resetting, tried re-plugging and tried going back to a previous firmware (with and without audio), but it doesn’t make a difference.

    So what happened?? Is this a known issue?? can it be fix?? any input is much appreciated.

    Regards
    PRC

    #21458
    BuckoA51
    Keymaster

    I would guess somehow your OSSC has had a little static electric shock unfortunately, it will need servicing.

    #21487
    PRC
    Participant

    Update:

    So today I took all my cable mess apart and checked everything. I found nothing wrong other than a bit of dust. I put everything back together to test it… and tadaaaa!, it’s working again lol.

    So what happened yesterday? I have no idea, I’m just happy it’s working again. I am a bit worry that this will became a recurrent situation, but for now I can relax.

    Regards
    PRC

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.