NES PAL and sampling settings

NewHome Forums OSSC & OSSC Pro OSSC – Discussion and support NES PAL and sampling settings

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #44948
    diablo_siffredy
    Participant

    Hi guys,
    I would like to ask for your help please : I’m facing some difficulties to get a clean and perfect display with my NES PAL, connected through OSSC 0.88 on my Samsung TV UE46F6500.
    I’m using 240_test_suite with everdrive to fine tune display settings.
    Line x2 [256×240 optimal] isn’t accepted by my TV so I moved to Line x3 [256×240 optimal] mode 8:7
    When I select Line x3 mode, my TV scale to 1280x720p/50p : is it normal behavior ?
    I think I have managed to get the best sampling phase which is around 225deg for my NES PAL.
    My main difficulty is that the display is cropped on both left/ride sides and I don’t know how to adjust it.
    Here are some pictures attached to show you my actual sampling settings.
    Google Photos share
    Hope you can help me to get a better output 🙂
    Thanks for your help !

    #44959
    diablo_siffredy
    Participant

    One more thing maybe : I did a try on Line x2 mode [Generic 4/3] and I think my TV handle this signal better as display moves to 720x576p/50Hz.
    But I still have both left and ride sides cropped 🙁
    Can you help me please ?
    Many thanks !

    #44995
    Harrumph
    Participant

    When I select Line x3 mode, my TV scale to 1280x720p/50p : is it normal behavior ?

    That figure is not what your TV is scaling to, it is the input resolution (i.e. the output from the OSSC). From your pictures, we see V.Active = 240, and 240×3 = 720 so it makes sense.
    I notice your image is also cropped vertically, so you could test other V.active, like 256 for 1280×768 output, or do Lx4 1080p (V. active is then 270). See the stickied tips & tweaks thread.

    Why your image is cropped horizontally is a bit weird. Looks like it crops 1 pixel each side (there should be an outer red border on the grid pattern, if I’m not mistaken the squares in the grid are 16×16 pixels, 16 across and 14 tall so 256×224). Then it would seem you should set h.active to 258, though I find that odd, afaik PAL NES does not output wider visible area than NTSC. Additionally it could cause the image to drop because then you have less standard image frame (1290×720 instead of 1280×720). Also I see you have sample rate at 341.1, that fractional samplerate might affect the width (I’m also not sure it’s needed for optimal sampling, 341 should work fine).
    Finally make sure any overscan (zoom) setting on your TV is disabled.

    Anyways, some things to try.

    #45002
    diablo_siffredy
    Participant

    Hi @harrumph,

    First of all, thanks a lot for paying attention to my display issue and thanks for all your advises.
    To be honest, your Tips&Tweaks thread is a must read and the famous one for all PAL OSSC users 🙂 I knew it already but, unfortunately, it didn’t helped me with my 1x horizontal pixel missing 🙂
    I double-checked into my TV menu and display is actually forced into 4/3, no zoom.
    I have adjusted a bit the V Backporch so now it’s should be better focus on center of the screen.
    I did some new tries in Lx3 and Lx4 and added new picture on the same Google Photo shared folder if you wanna have a look on it.
    I also have checked there’s no horizontal/vertical mask set, that’s ok.
    If you can help me to investigate this strange display issue, I really appreciate your time !
    Thanks a lot again,
    Cheers
    Cyril

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.