New OSSC user; TV compatibility issues(?)

NewHome Forums OSSC & OSSC Pro OSSC – Discussion and support New OSSC user; TV compatibility issues(?)

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #24404
    DWN-016
    Participant

    Hello, I just recently bought an OSSC and set it up for use with my PS2. My TV didn’t like the 240p output on PSX games through component cables, so I hooked it into the OSSC first to see if it would fix my problem. Strangely, it seems like my TV doesn’t like the OSSC’s output in general for whatever reason? With the PS2 off, it detects a signal going in and calls it “480p”, however all I get is a black screen; not even the gray test pattern comes up. with the PS2 turned on and plugged in using component, my TV recognizes and actually plays the sound from the OSSC, but still, the picture is black.
    I researched some other discussions on here and the only person who had a similar problem to me was just told to get a new TV, and… yeah, I need a new TV regardless. Though something else strange that I found was that, for some reason when the PS2’s powered on, the OSSC’s LCD screen says the resolutions it is receiving are 525i and 263p (both at 59.94 hz) for 480i and 240p, respectfully. I’m in America and all my systems (and my TV) are NTSC, so is this normal? Perhaps there’s a region toggle for input/output in the OSSC’s menu I have to switch?

    #24405
    BlueStinger
    Participant

    For the resolution “issue”, it’s actually normal, apparently the OSSC displays the number of lines rather than the resolution. Someone taught me that a few days ago, I don’t really understand why but that’s how it is. Anyway, this is normal.

    As for your main issue, I just have a couple of advice :
    -share the specs of your TV, brand, series, resolutions etc, it might be helpful for people who want to understand your issue.
    -try to activate the “PC” mode, maybe your tv will accept more “strange resolutions”
    -try another HDMI cable (we never know)
    -can you try on another tv ? So we can rule out the OSSC as the source of the issue

    Also, have you tried 240p games in 3x, 4x and 5x mode as well ? Your tv doesn’t accept any of those ? Try to test all the possible configurations and with as much consoles as you can.

    I know I’m not very useful here, but unless people have a ready-to-go solution for you, they’ll probably going to need those answers, might as well give them as many tools as you can now so they help you quickly and effectively.

    #24406
    Steo
    Participant

    The one thing you can try is to switch TX mode to DVI under Output Settings, though if that does work, you won’t get sound through the HDMI cable. Worth a try also, but what ^ says is right. Knowing the type of TV etc. could make it easier for people.

    #24407
    DWN-016
    Participant

    Sorry I took a bit to respond, but my TV is by Dynex and it’s model name is DX-32L100A13. Aside from its firmware version being 568MS0002A5833, I couldn’t find any more info in regards to its specs. And I couldn’t really find a “PC mode” or anything of the sort; it’s really barebones in terms of features. It’s just a regular 1080p TV.
    And yeah, I’ve tried it in 2x, 3x, and passthru, but none worked.
    I can test the OSSC on my PC monitor, but I haven’t been able to do so yet because of the wire mess. Even then though I doubt it’s a problem with the OSSC considering that the sound works just fine, and that my TV is a pretty lackluster one to begin with.

    #24411
    Harrumph
    Participant

    The grey test pattern has standard 480p timings and should be detected by all displays. If you don’t see the test pattern, then either there is something wrong with your HDMI cable, or your OSSC.
    Would be good if you could confirm on another screen, and using a different HDMI cable.

    #24413
    Steo
    Participant

    I assumed that, but another user claimed to have no test pattern on their monitor either unless they used DVI mode. I thought it was worth mentioning just in case.

    #24414
    BlueStinger
    Participant

    oh, and also you should try the other HDMI ports if you have other ones. Not all HDMI ports are equal.

    #24415
    Steo
    Participant

    Yeah that too, see if one is labelled as something like DVI. Older Samsung TV’s used to label a port like that.

    #24418
    SavagePencil
    Participant

    I looked up the manual for that TV ( https://files.bbystatic.com/00DmNnVrlKmhfloVAhQ%2BHg%3D%3D ) and HDMI port 1 doubles as a DVI port.

    #24419
    BlueStinger
    Participant

    @DWN-016 read the post above, it might help you. Then, check the page 31 of your manual, you can change the label of the inputs. You can make custom labels and call the input “PS2” if you want, but try to use the pre-made labels, try the “PC” label if you find one. On my TV, these label DO HAVE an impact even though it’s not disclosed upfront.

    Check the page 22, apparently there is a “audio only” option on your tv…

    #24420
    DWN-016
    Participant

    Thanks, I switched to DVI mode and the video output works now. Plugging the PS2’s audio cables directly into the TV’s “PC audio in” jack gives me the audio, so it’ll thankfully last me for now. When I end up getting more consoles though, I’ll have to get a new TV anyways, since I can’t be swapping out audio cables for each console. In any case, I’m glad my OSSC isn’t broken and it’s just that my TV’s from the stone age. Thanks a lot for the help!

    #24421
    BlueStinger
    Participant

    Once again, @Steo has been helpful, I’ve been useless ^-^ Glad it’s fixed now, enjoy those sexy pixels !

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.