New Retro Tink 2x mini not working anymore

NewHome Forums RetroTink Products New Retro Tink 2x mini not working anymore

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #46110
    Mats Ole Larsen
    Participant

    So I ordered a retro tink 2x mini from you about a month ago. It arrived today. I am using it with my Commodore 64s and Svideo cable. Have HDMI plugged into a LCD TV. It was working fine for about an hour. Then as I was playing a game I suddenly got a black screen and no sound. After this I never got a picture from the retro tink. It starts with a short blink red LED then it goes green LED and stays green. No test picture or anything. No white LED for Svideo anymore. It seems dead. I have many C64s and 5v power supplies to use for the retro tink so that is not the issue. As I said, it doesn’t even come up with the test picture and no white or yellow LED for S-video or composite anymore. And no signal on the LCD TV. What could be causing this? It there some kind of pico fuse or anything inside the retro tink 2x mini? This is really sad as I waited for a month to get it and it only worked for an hour.. What could be the issue?

    Edit: Tried reflashing the firmware. And that went sucessfull. Following your instructions on how to flash. Still same issue. Also took a look around the PCB and none of the small picofuses I measured was faulty. A short red flash when I give it power, then the green LED stays on. No test picture anymore and no changing of the LED to white or yellow when I try svideo or composite. Dead as a doornail.

    #46428
    BuckoA51
    Keymaster

    Get in touch via the contact form and we’ll arrange an RMA for you.

    #46435
    Mats Ole Larsen
    Participant

    Hi, there. Already been in contact with Mr. Buxton via email. The unit has been shipped back for RMA. Thanks

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.