No LEDs, Faint LCD Backlight, Suspicious U12/VCCINT, nSTATUS

NewHome Forums OSSC, OSSC Pro and DExx-vd isl OSSC – DIY Support No LEDs, Faint LCD Backlight, Suspicious U12/VCCINT, nSTATUS

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #10175

    I’m hoping to get some advice on where I should be looking/what I should try next. This is my second attempt at this kit – the first time I bridged something in TVP7002 that caused me to fail Marqs’ “verification” check in the instructions and (perhaps foolishly) decided I would be more careful the second time.

    What’s strange to me is if I leave the board plugged in for a few minutes and then turn it on I see both LEDs flash and the LCD backlight turns on then almost immediately both LEDs go out and the LCD backlight becomes very dim. I never see characters on the LCD (I’m still using the pre-flashed firmware chip from the Advanced DIY kit.)

    Here’s what I’ve noticed so far:

    • U12 is getting 3.3v and outputting 1.35v, which seems high because U14 is outputting 1.2v and they are both TLV70012. Altera seems to want 1.2 for VCCINT.
    • I swapped U12 with the same regulator for my 1st attempt board and got the same result, which makes me think U12 is ok and the problem lies elsewhere.
    • R37 only gets 0.38v from pin 51 (LCD_BLEN/IO51) on EP4CE15E22. I’ve verified that there’s no continuity between pin 51 and the adjacent pins.
    • R16 gets 3.3v from the DVDD3V3 side but I always read 0v from the other side when power is on.
    • R16 has continuity to pin 9 (nSTATUS) and that pin does not have continuity to the adjacent pins.
    • R17 gets 3.3v from the DVDD3V3 side but I always read 2v from the other side when power is on.
    • R17 has continuity to pin 14 (nCONFIG) and that pin does not have continuity to the adjacent pins.
    • Per the tips in “LIGHTS ARE ON, BUT NOBODY’S HOME”, I’ve made sure continuity is good and there are no bridges on the following other pins: CLK27, FLASH_nCE, DATA0, DATA1/ASDO, DCLK
    • Aside from VCCINT being 1.3v, all the power supply pins on U1, U2, and U3 seem to read the correct voltage and are not bridged to adjacent pins.
    • I can make the LCD backlight stronger by touching Q1 and R40.

    One last thing I should mention is that I don’t have all the connectors soldered yet. Specifically, I haven’t yet added the VGA, RCA, SCART or 1/8″ audio connector. I wanted to make sure everything worked before I added those and restricted soldering iron access. I can’t see how the lack of those could be detected by the board but perhaps I am wrong.

    At this point I’m out of ideas. I suppose one thing to try would be to remove and resolder U2, but I don’t have hot air and don’t know how to remove such a large QFP IC without that. However, if people feel that the only logical explanation for my issues lies under U2 I suppose I’ll have to bite the bullet and invest in hot air or investigate alternate methods for removing large ICs.


    Your U12 is broken and almost certainly has damaged FPGA too. There has been a couple identical cases which were resolved by changing these components. Where did you get U12 and FPGA btw? I’ve started to suspect that some of the TLV70012s I ordered from Mouser were bad, but I didn’t bump into any of those when I assembled prototype boards.


    This story has gotten very strange. After cleaning the board with alcohol and testing various points for connectivity, the board suddenly started working long enough for me to flash 0.74 with a USB Blaster. I started to add the remaining connectors (re-testing after each one) and after adding the audio the board no longer booted.

    I tried putting U14 from the old board on U12 of the new board and with the output legs raised I still read about 1.35v. I even tried putting U14 from the new board on U12 and got the same result, which surprised me because U14 on the new board works fine. The only explanation I can think of is that the FPGA is now so damaged that something about it caused the a working regulator to fail even with the output legs raised.

    At this point I don’t have any other ideas but to accept your diagnosis of bad TLV70012s from Mouser US and probably busted FPGA. Is there a way to tell for sure if the FPGA is gone?

    Do you have any advice on making sure the replacement U12 is working correctly? If I only connect the 3 input pins, should I read 1.2v? Should the presence of the FPGA, regardless of if the U12 output pins are connected, affect the output of U12?


    Like an idiot, I ripped up a bunch of FPGA pads as I was cutting off the FPGA legs. Too much lateral pressure, should’ve pushed straight down. Debating if I should order DIY board #3 or just accept the premade board. I really wanted to be able to say that I built this kit.


    Oof, I’m sorry to hear that, I did the same thing to my first board. I can’t help you as far as deciding which path to take here, but I just wanted to voice my support.


    Thanks, Aether. It helps to hear that someone else struggled, too. It appears my choice has been made easier by the fact that there are no more DIY boards available 🙂

    I am lucky in that I was able to get an assembled board from the waiting list as an insurance policy in case my DIY efforts failed. I had hoped that my DIY success would mean that assembled board could be sold at cost to someone, but no such luck.

    Perhaps I’ll try again someday if the DIY boards come back in stock. This time I’ll know to build the power lines/regulators first and test all of them before adding the ICs.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.