No line doubling possible in 480p since firmware 0.90a

NewHome Forums OSSC, OSSC Pro and DExx-vd isl OSSC – Discussion and support No line doubling possible in 480p since firmware 0.90a

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #53273
    MelvinSmiley
    Participant

    I have the OSSC 1.7 from VGP and use it with my Pal PS2 with softmod. Line doubling with 480p input used to work before I updated OSSC firmware from 0.81 to 0.9a.

    Now however all I get is a black screen. My settings are the same as before and I tried turning things on or off, nothing changed. Black screen with Line 2x, passthrough works.

    Vesa 640×480 mode in “Sampling options” also works with Line 2x for some reason but the right part of the screen is cut off and there is a huge black bar on the left side of the screen.

    This is all very disappointing tbh., I think in hindsight I wouldn’t even have ordered the OSSC because I mostly play PS2 and I don’t want to destroy my IPS-Panel TV with its bob deinterlacing. Now even 480p line doubling doesn’t work, what is the point of this device at all?

    #53275
    BuckoA51
    Keymaster

    Which TV are you using? Try to perform a settings reset on all of your profiles, be sure that they are saved, and try again. Nothing should have changed regards 480px2 in the firmware update.

    #53277
    MelvinSmiley
    Participant

    My TV is a LG Nanocell 889 55-inch from 2021. I tried resetting the settings, it’s still the same. I connected my Dreamcast and it’s the same behaviour, no line doubling possible with Dreamcasts VGA 480p input. Now my OSSC is a glorified analog to digital converter and does absolutely zero video processing. I think it’s faulty and I’m going to have to return it. Like I said, with firmware 0.81 everything used to work fine.

    Edit: Strange, but my Dell 2721dgf monitor does allow line doubling, so maybe it’s this crappy nanocell tv after all. Still don’t understand why line doubling worked with 0.81 but at least my OSSC seems to be fine, that’s something.

    #53283
    BuckoA51
    Keymaster

    Can you roll back to the old firmware and try it again? Nothing /should/ have changed, but based on this maybe something has. I know on the C9 I can still do 480p x 2 on the latest firmware.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.