No signal when using PS2 HD Retrovision component with OSSC

NewHome Forums OSSC & OSSC Pro OSSC – Discussion and support No signal when using PS2 HD Retrovision component with OSSC

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #46644
    DragonQuarter
    Participant

    My Xbox and Wii output just fine on my 4KTV through Component –> OSSC –> HDMI but I’m getting zero luck with my PS2 and I’m not sure why.

    Fat PS2 (SCPH-39001)
    HD Retrovision Component Cables
    Kaico OSSC Firmware 0.88
    Samsung 49 Class LED Q6F Series QN49Q6FN

    In PS2 System Configuration, Y Cb/Pb Cr/Pr is selected (checked via Composite to my PVM)

    On the OSSC, I’ve confirmed that the Red/Green/Blue connectors are in the right spots.
    On the OSSC screen, it reads “AV2_YPbPr 525-i 15.71kHz 59.87Hz

    And yet, when my TV attempts to read the signal, it goes into a “No signal detected” screen. It doesn’t do this for other component consoles like Wii or Xbox, so I’m not sure what’s the deal. I tried connecting to the OSSC’s HDMI to my 1080p BenQ PC monitor instead, and that also got no signal.

    This leads me to believe the issue is either the PS2 (which would be weird, composite worked just fine), the HD Retrovision component cables (thinking of returning them), or the OSSC itself.

    Appreciate any help with this! Part of me is thinking of saying “screw it” and getting SCART cables instead, although I’m not sure from where.

    #46767
    BuckoA51
    Keymaster

    Same in passthrough and 2x mode?

    #46782
    DragonQuarter
    Participant

    Sorry for not updating this, but I realized the issue. Just a dumb user error by me. Rather than working off the “Reset Settings” / setting things to default, I was using one of my Xbox presets to work from, which is why I wasn’t getting a picture. Resetting the settings and then working off that did the trick. Thanks and sorry!

    Meanwhile I’m using this video for figuring out best settings for PS2 component via OSSC with my 4KTV: https://youtu.be/UvkjQIqpZFc

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.