Original Xbox – red and blue swapped in line2x mode

NewHome Forums OSSC & OSSC Pro OSSC – Discussion and support Original Xbox – red and blue swapped in line2x mode

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #37013
    Hedini
    Participant

    Hi,

    first of all, I am completely new to the OSSC and used it yesterday for the first time… unfortunately with my original Xbox and so I encountered a strange behavior of the device. I am not sure if I made any errors, but this is what I saw:

    The colors blue and red are swapped but only when the OSSC is in line2x mode.
    I tried two different original Xbox (the bulky, classic ones, both consoles have different PCB-versions) and saw the same error. My OSSC is version 1.6 and it does not matter if I use the RGB-input or the component video input. When I switch it to line1x or line3x (or higher), the colors are correct again. So only line2x is affected.

    I updated the firmware from 0.81 to 0.85 but it did not fix it.
    OSSC-settings are factory-default, so I didn’t change any of them.
    The cables I used are the original, standard Microsoft RGB-Scart-cable with SPDIF-breakout box and a Monster composite cable with SPDIF-breakout.

    The settings of my Xbox console are 16:9 with PAL 60hz (although the dashboard is in 50hz).

    Is this a firmware bug?
    I read in two other threads that there are feature requests pending for a RGB-swap in the firmware, but it did not seem related to what I experienced so far.

    If there any any further tests or information needed to narrow down that behavior, please ask and I will do what I can to provide them.

    #37014
    BuckoA51
    Keymaster

    Can you try another display?

    #37016
    Hedini
    Participant

    What the…?!? 8-(
    Okay, err, conclusion so far:
    Toshiba 42ZV555D = correct colors in line2x
    Sony KDL-75W855C with latest firmware directly connected = correct colors in line2x
    Sony KDL-75W855C connected over Yamaha RX-A3030 AV-receiver with latest firmware = red/blue swapped in line2x

    I am a bit puzzled right now. Does this mean that there is a bug in the Yamaha AV-receiver or that the OSSC-settings need to be tweaked?

    In the meantime I changed a few settings in the Yamaha and found out it’s the video processor that causes the issues:
    – in “direct” mode I can see line1x (576i) and line2x (576p) but nothing above that resolution
    – in “processing” mode I can see all line-modes except line5x (unsupported) but line2x has swapped colors

    (edited the initial post as it wasn’t the Sony, but the AV-receiver who swaps colors)

    • This reply was modified 5 months, 2 weeks ago by Hedini.
    • This reply was modified 5 months, 2 weeks ago by Hedini.
    #37046
    Hedini
    Participant

    A few minutes ago I connected my PS2 using a component cable and saw the same results, so it is not limited to the Microsoft Xbox classic.
    When I switched my PS3 (which is also connected over HDMI to the Yamaha) to 576p, I got a 576p picture with correct colors.

    I guess the OSSC is doing something with the 576i to 576p (line2x (bob)) mode that seriously annoys my AV-receiver, but I have no deeper knowledge about video signals to inspect that issue further on myself. 🙁

    When I switch the OSSC in 576i to pass-through, the colors are correct, too.

    • This reply was modified 5 months, 2 weeks ago by Hedini.
    #37087
    BuckoA51
    Keymaster

    There’s likely a bug in the Yamaha, yeah.

    Yeah you definitely don’t want to be using your AV receivers video processor anyway, as they tend to have quite barebones features, what features that are there are optimised for video not graphics/gaming and they add a lot of input lag.

    #38669
    Zacabeb
    Participant

    I encountered the same issue with a Yamaha RX-V685.

    A workaround I found was to increase or decrease the horizontal backporch length by one. This solved the problem in Line2X mode, but might not do so in other modes. But on the cheaper Yamaha receivers you get horrible color resolution (it subsamples the input in YCbCr 4:2:2 and scales it up in 4:2:2). I’m not sure if that’s true also for the higher end models.

    Update: With some further experimentation, I discovered that the RX-V685 is unable to render its menus if it gets an unusual signal and video processing is enabled. This too might vary between models.

    • This reply was modified 3 months, 3 weeks ago by Zacabeb.
    #38673
    BuckoA51
    Keymaster

    That’s definitely something you might encounter using the video processors in AV receivers. Remember that all movie content is YCbCr 4:2:2. why spend money giving full RGB bandwidth when you can get away with less and most people will never notice. Manufacturers could not care less about gamers, sadly.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.