OSSC and Magewell Pro Capture HDMI Dual – Flickering Issue

NewHome Forums OSSC & OSSC Pro OSSC – Discussion and support OSSC and Magewell Pro Capture HDMI Dual – Flickering Issue

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #25667
    Jademalo
    Participant

    I’m at a bit of a loss with this, since I’m struggling to figure out where the issue could possibly lie.

    I’m in the process of setting up a capture setup for a friend. They have an RGB modded NES and SNES. They’re connected to the OSSC via SCART into AV1. This is then connected to the Magewell card, and set up as a source in OBS.
    No matter what I seem to try, the resulting image flickers. No matter the config of the capture card or the OSSC, I get this flickering. I’ve tried all sorts of framerates, resolutions, tried it in virtualdub, literally everything I can think of.

    Regardless of the config on the OSSC, we get this issue. We’ve tried default settings, SNES specific settings, and all sorts of weird things in between.

    If the OSSC is plugged into a monitor, it works absolutely fine. We also have a second OSSC, and it too works absolutely fine. This issue is only when it’s connected to the capture card.

    Any ideas? I’m totally at a loss here.
    Drivers are up to date, OSSC is up to date, and practically every step of the chain has been eliminated as the issue aside from the capture card. I’m fairly sure that a Magewell Pro Capture HDMI Dual should be able to handle 640×480/720×480/768×480 from an OSSC though, so there’s definitely something weird going on.

    Thanks!

    #25668
    nmalinoski
    Participant

    Are either your NES or SNES fitted with a dejitter mod (Or a NESRGB 2.x in the NES)? These consoles are known for having irregular sync cadences, which a lot of digital video processing hardware doesn’t like.

    #25669
    Jademalo
    Participant

    Not that I’m aware, but I’ve just found out that the extremely weird thing is this same issue happens with the N64. My original thought was it was something to do with that, but since the N64 has the same issue I’m beginning to think it’s something else.

    Plus, I’ve definitely seen a couple of people say that their OSSC works fine with the Pro Capture HDMI, so it *should* be fine.

    EDIT: SNES is an unmodded 1Chip

    #25671
    marqs
    Participant

    You might want to try the display test suite firmware (especially T6 and T7). If those result to similar behaviour then the capture card is the most likely culprit.

    #25672
    Jademalo
    Participant

    Thanks marqs, I’ll give that a shot when we get the chance.
    Two weird things of note – Firstly, the standard test pattern the OSSC has seems to work absolutely fine. Second, the N64 doesn’t. I was under the assumption that the N64 runs at NTSC spec speed, so if that’s not working then it’s extremely weird.

    #25673
    Teddy Rogers
    Participant

    Have you tried using the FilterProperty tool to inspect the input from the OSSC? It may help to diagnose the problem. FilterProperty can be found in one of the older Magewell SDK’s. I have uploaded it here if you can’t find it…

    https://rapidgator.net/file/8da93c547326c624a23e81b0c04e2838/FilterProperty.zip.html

    Ted.

    #25674
    Jademalo
    Participant

    Thanks, I’ll give that a look. That may shed a bit of light on it.
    I did check with a null filter in GraphEdit, and in the device properties of the magewell card it seemed to be showing everything correctly.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.