OSSC detects wrong resolution (I think)

NewHome Forums OSSC, OSSC Pro and DExx-vd isl OSSC – Discussion and support OSSC detects wrong resolution (I think)

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #9485

    Hello and thanks for an awesome product. Just got it today. Everything works so far, apart from one thing.

    The OSSC is able to display all resolutions when playing PAL Playstation 2 games, but it won’t display some PS1 games when played on the PAL Playstation 2.

    PAL PS2 console, PAL PS1 game, works:
    625i 15.62 khz 50.00 hz

    PAL PS2 console, PAL PS1 game, doesn’t work:
    314p 15.62 khz 49.76 Hz

    What could be the problem?
    Is 314p a real resolution that the OSSC is detecting? (Haven’t been able to find it on the net)
    The problem is there with both component and RGB-SCART-cables.

    Pal Sega Master, SNES and Gamecube are working fine with the OSSC through RGB SCART.


    314p refers to total number of scanlines and it’s correct value for PAL PS1. Either your TV does not accept linedoubled scanline count (628) or refresh rate (49.76Hz), most likely the former. For reference, “standard” 50Hz progressive signal is 625p@50.00Hz.


    Thanks a lot marqs.

    Is there something that might be able to rectify the issue? Some settings on the OSSC?

    An upscaler to pass the OSSC through or a new TV isn’t likely in the next couple of years, for me.
    At least it’s only PS1-games I have problems with, which can be played on the PS3 (Though emulated).


    Try playing with the PL-Coast values a little?


    I’ve played with a lot of settings now, nothing seems to work unfortunately.

    I’ve tested the signal through the horrible upscaler in my surround receiver, so the signal gets through. It only works when the receiver upscales to 1080i unfortunately, so I can’t use it.

    I’ll just hope a future firmware update might rectifies it 🙂


    I’ve encountered a TV that didn’t like PAL PS1 games via OSSC too unfortunately.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.