OSSC Doesn’t Boot (Blown Fuse Replaced)

NewHome Forums OSSC, OSSC Pro and DExx-vd isl OSSC – Discussion and support OSSC Doesn’t Boot (Blown Fuse Replaced)

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #43024
    Guffman
    Participant

    Hey guys, I had a whole bunch of tabs open from other threads, but my computer decided to update on me and none of them saved, so I figured I’ll just finally make my own darn post.

    I made the mistake of plugging in an incorrect PSU, and blew the fuse in my OSSC that is commonly the victim of such foolishness. I think it’s F1 or something on the board… Anyway, thanks to you guys, I replaced the fuse with one from Mouser.

    My OSSC now comes on, but has nothing on its own screen, nor does it output any video. I’ve tried plugging in a PS2 via YPbPr and using the onboard buttons, but no luck. I’ve also tried using the remote, and while there was a response from the IR signal (green light blinks), nothing actually happens with the OSSC. I should note that the thing actually smoked when I got it to power on with the correct PSU, but I thought it might’ve been some impurities at the solder joints from my new fuse. The device still powers on, so whatever smoked didn’t destroy everything, but I’m wondering what my next step should be.

    I’ve read that I should next replace U5 and U6, if I remember correctly (I’m still trying to get a handle on soldering, I’m still a novice), but could whatever smoked have fried the whole thing? Thanks, as always, for everything tall do!

Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.