OSSC, MClassic, and HDMI Switcher Compatibility

NewHome Forums OSSC, OSSC Pro and DExx-vd isl OSSC – Discussion and support OSSC, MClassic, and HDMI Switcher Compatibility

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #38132
    Luchario
    Participant

    Hello, I am looking to see if there is a fix that can solve my issue. Here is a list of the configurations that work fine with my setup:

    OSSC > TV
    OSSC > MClassic > TV
    OSSC > Switcher > TV
    OSSC > MClassic > Switcher > TV
    Other Devices > Switcher > MClassic > TV

    This is the one that does not work:

    OSSC > Switcher > MClassic > TV

    When connecting in this configuration the image cuts in and out.

    I am using 18 GB/s 4k@60 Hz cables. I have tried other cables, a different Switcher as well.

    Has anyone used a similar setup and had this issue? Any suggestions?

    #38135
    BuckoA51
    Keymaster

    Which TV are you using?
    Which switches?
    using home theatre system, soundbars etc or just the TV?
    any ARC or eARC in your setup?
    Tried HDMI and DVI mode on the OSSC?

    #38137
    Luchario
    Participant

    I’m using the following:

    TV – Hisense 55H8F 4K TV
    HDMI Switchers – Kinivo 550BN 5×1 4K@60 HDMI Switch and a Monoprice Blackbird 4K Pro 4×1 HDMI 2.0 Switch
    Soundbar – I’m using a Samsung – 4.1-Channel 240W Soundbar System but the TV connects to it directly, there’s no passthrough from the switcher to the soundbar.

    I’ve tried connecting the HDMI cable into both a regular HDMI port as well as the ARC port of the TV.

    I don’t have anything connected to the Soundbar as I just have a digital in from the TV and all HDMI ports connect to the TV directly.

    I’m not sure what you mean by HDMI/DVI mode. I have tried connecting the OSSC directly to the TV using HDMI if that’s what you mean.

    Thanks!

    #38391
    BuckoA51
    Keymaster

    DVI mode on the OSSC – Output Opt->TX Mode

    #38407
    Luchario
    Participant

    Hey!

    Thanks, that seems to make the video work fine. I’m guessing because it’s DVI mode audio does not passthru anymore though. Was the audio passthru the issue then or is there something else in DVI mode that lets the video work well?

    #38409
    Luchario
    Participant

    Actually, just tried switching between HDMI (RGB) TX mode w/o audio input and DVI mode and I don’t think that’s the issue. I’m guessing it’s just a data transfer issue or maybe how HDMI transmits the signal vs DVI.

    I’m pretty certain the issue is the mClassic, but if it’s not maybe it’s the cables? I’m not sure if that is the case since I’m already using 4k@60 18gbps cables, but would 48gbps cables actually make a difference here or is it most likely just an issue with how the mClassic interprets the OSSC signal coming through the HDMI Switch?

    Even when I have the mClassic in passthru mode (technically should be off) it still has this issue.

    #38425
    BuckoA51
    Keymaster

    Definitely an issue with MClassic then, worth asking their tech support for help?

    Changing cables isn’t going to help. The other thing you could do is just route the analogue audio separately.

    #38432
    Luchario
    Participant

    Yeah, that’s what I ended up doing for the meantime. I did contact their tech support and this is what they messaged back:

    “Sorry you’re having problems with your setup. We see this problem occasionally happening when there is a non HDMI certified device, and/or a non HDMI 2.0 rated HDMI switch. Non HDMI certified devices tend to produce more signal jitter than certified HDMI devices, and low rated HDMI switches exacerbate the problem further. And when the mClassic upgrades the picture to a higher resolution, it increases the TV’s sensitivity to jitter. Using low quality or cables with internal damage can also create jitter in the signal, but it sounds like that’s unlikely.

    In conclusion, I’d recommend trying another TV to see if it’s the TV that’s just very sensitive to jitter. (Samsung TVs seem to be the most sensitive to signal noise).
    And which HDMI switch are you using?”

    I wrote back with my setup a few days ago and now again with the information that DVI mode works but I’m still waiting for a reply.

    Thanks for the help so far, I appreciate it!

    #46722
    corkerss
    Participant

    Hi Luchario,

    Did you ever get a response from Marseille for this? I’m having the same issue and it’s driving me mad 🙂

    I have the OSSC going in to a HDMI switch then the mClassic, then my TV – I have three consoles connected to the OSSC:
    VGA: Dreamcast
    RGB SCART: SNES
    Component: Playstation 2
    (all are high quality cables)

    The Dreamcast works fine, no issues, but both the PS2 and SNES constantly cut in and out. I tried changing to DVI mode but that led to the SNES screen going green (!?) and have tried settings from multiple other threads but nothing has worked. All of the cables are high quality 4K HDMI’s and the HDMI Switch is a 4K@60Hz switch. My TV is a Samsung 40″ 4KTV but have had the same issue when connecting to an ACER Predator 144Hz Monitor.

    Any held would be much appreciated 🙂

    Thanks!

    #47344
    Luchario
    Participant

    Hi corkerss,

    Unfortunately, I didn’t get any follow-up from Marseille for this particular issue. I’m still having the same issue for the Wii, though my PS2 through SCART seems to work fine (although I’ve played PS1 games mostly, not PS2. Then again the SNES is also 240p so it should be the same situation, unless the Hz are the problem). For the Wii I’ve just ended up connecting the mClassic directly to the OSSC whenever I do use it and then just move it back to the Switcher for everything else.

    I’ve found the issue works even in “off” or “passthrough” mode for the mClassic so I’m assuming the signal being passed through is still being chopped up for some reason. Since Marseille can’t update the mClassic (no firmware updates are possible) I think we may just have to wait for an updated version of the mClassic, maybe one that supports HDMI 2. Though, this is also an assumption on my part, thinking that maybe the issue is the HDMI 1.4 of the mClassic.

    Not sure what else to do…

    Please let me know if you think of anything else.

    Thanks!

    #47345
    Luchario
    Participant

    Hi corkerss,

    Actually, just searched my email and did find a reply from Marseille from about a couple weeks ago.

    This was the reply:

    “When the jitter coming from the source accumulated large enough which TV cannot receive, you will see flashing on TV.
    From the test result you have done, looks like…
    1. When OSSC output 480p, it generate large jitter,
    2. When it go thru HDMI Switch, the jitter get increase
    3. Then mClassic upscale from 480p to 1080p, the jitter become too big that TV cannot tolerant.

    The solution is to try different HDMI switch, or use a HDMI repeater which can clean up the signal and remove the jitter.
    https://www.bestbuy.com/site/insignia-hdmi-cable-repeater-black/6324285.p?skuId=6324285&ref=212&loc=1&extStoreId=142&ref=212&loc=1&gclid=CjwKCAjwh7H7BRBBEiwAPXjadm1ITnNK5UyQuzfwCWdRp1R3hmTvvxqwle5lN6V99W1J0kcgDxO3JRoCYscQAvD_BwE&gclsrc=aw.ds”

    That being a link to BestBuy’s Insignia Cable Repeater. I guess I’ll try it and give it a shot to see if it works. I’ll report back with whatever results I get…

    I may also try a CableMatters repeater, it’s about $10 cheaper (on Amazon) and I believe they make good quality accessories most of the time.

    #47454
    Luchario
    Participant

    Well,

    I can confirm that neither HDMI repeater that I used fixed the problem. I will contact Marseille about this again and see what they say…

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.