OSSC PAL Optimal Timings

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #42270
    Opaque79
    Participant

    So I’ve managed to get 3x mode with 320×240 optimized mode working decently. Only useful for non-optimized N64 games and all consoles prior.

    Are there any tweaks to force 4x optimized modes? Or would I need to use a PC monitor for that?

    #42299
    Harrumph
    Participant

    Could you clarify “all consoles prior”? The optimized modes (and importantly, sample rate of the optimized mode) should be matched to the specific console dot clock. For example 320×240 is appropriate for N64 (with 386.6ish samplerate), but not for SNES which needs the 256×240 mode (with 341 samplerate).

    (well technically, no console “needs” 320×240 or 256×240 since you can set any samplerate for either of them, but then you don’t get the right horizontal multiplication, so the aspect ratio would be more off if appropriate mode is not selected)

    Also note that some games have double horizontal resolution (mainly noticable with text), then you should use 512×240 mode and double the samplerate.

    See further here: junkerhq.net/xrgb/index.php?title=Optimal_timings
    and here: videogameperfection.com/forums/topic/best-n64-settings/

    If your N64 is PAL, odds are you need to lower v.active to 270 to get it working in x4 mode (270×4 = 1080). See also: videogameperfection.com/forums/topic/tips-tweaks-lx3-lx4-lx5-modes/

    #42300
    Opaque79
    Participant

    All consoles prior meaning NES, SNES, Master System and Mega Drive.

    For x4 mode, the 270 tweak onlyw works for the generic mode on my TV. Optimized modes in x4 will not display. In x3 mode with the PAL tweaks, only 320 and 256 modes display.

    #42302
    Harrumph
    Participant

    Probably pixel clock is a bit too low in optimized mode compared to generic mode (when tweaked for PAL 1080p).
    You can try increasing h.active for 320×240 to 360, as you may get a more valid active frame (1440×1080).

    EDIT: actually an idea can be to use 256×240 mode to increase pixel clock (horizontal is multiplied by 5 as opposed to 4 in 320opt mode). You will need to experiment with h.active to get a suitable active frame, and zoom control on your TV to get acceptable aspect ratio.

    #42304
    Opaque79
    Participant

    Neither of those work. My TV won’t accept any optimized mode in x4 mode.

    #44026
    Opaque79
    Participant

    Been looking into this more. I can use 5x optimized modes on PAL consoles (each tweaked to their own).
    I tested 4x optimized on PAL with my PC monitor and it did work but with the cutoff that occurs on PAL. On compatible displays, increasing the V. Active to 270 can fix this but on my TV, this isn’t an option.

    Going through my N64 games, the following games are unaffected by cropping

    Turok 2
    Wave Race 64
    Super Mario 64
    Duke Nukem 64
    MArio Kart 64
    Bomberman 64

    The following games have workaround in the form of letterboxing

    007 The World is Not Enough – Activate Hi-Colour mode
    Goldeneye 007 – Use Wide or Cinema screen size
    Perfect Dark – Same as Goldeneye 007
    Army Men – Sarge’s Heroes – Use letterbox view mode

    So as always, it is dependent on the display with PC monitors and 4k TVs more likely to cope.

    Just to note, my PC montitor will not accept 5x from a PAL console but my TV will.

    #44087
    Chris1479
    Participant

    Interested to hear more about optimised PAL timings for PS1, Saturn and Dreamcast. Tried Firebrandx’s profiles and they don’t work whatsoever on my PAL consoles.

    #44088
    Opaque79
    Participant

    Haven’t looked at Dreamcast much and I don’t own a Saturn.

    PS1 is difficult as there are so many resolutions that the PS1 uses.

    Firebrandx’s profiles are for NTSC consoles. You also need to consider that some picture info is lost on PAL sources which can be a potential issue on PS1 and N64

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.