Ossc with component cables (ps2) too dark

NewHome Forums OSSC, OSSC Pro and DExx-vd isl OSSC – Discussion and support Ossc with component cables (ps2) too dark

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #22644


    I’ve recently purchased an ossc, and I’m really happy with it. 8 and 16 bit games look great. However when trying to use it with my ps2 via component cables the image is too dark.

    My girlfriend was trying to watch Game of Thrones on the ps2 (it was the only dvd player we had hooked up to the tv at the moment) and in some scenes all it looked like was a black screen with faces floating around. I’ve noticed the darkness while playing games as well but just thought this was how the areas were supposed to look.

    At first I thought it was poor quality component cables, but there is no problem when plugging it directly into my tv. There doesn’t seem to be an option to adjust the black levels through my tv menu, and adjusting the component contrast levels on the ossc helps but causes the image to be way over saturated (as expected). Also I’ve made sure that my ps2 is set to Y/Pb/Br and not RGB. I’m thinking of just purchasing a rgb scart cable for the my ps2. Would this help? Is there any thing else I should try first? Thanks.


    I’ve got official PS3 component cables on my PS2 (PS2 set to YPbPr). Have also tested with a retrogamingcables SCART cable (PS2 set to RGB), and don’t notice any difference in color levels. This is with a fat PS2.

    Just to confirm, you have the PS2 set to YPbPr, not RGB?

    Is it possible that the TV is changing a viewing mode, possibly triggered by some sort of detection of the PS2 signal via the OSSC? I’ve noticed a couple times that my TV randomly disabled ‘game mode’ and change the Picture Mode, the latter of which resulted in a brighter image than I prefer.

    Maybe worth investigating, at the TV.


    Is it possible this is being caused by an issues related to an interlaced signal? Can you try changing the output on the ossc for 480i (or whatever the pal equivalent is if applicable) to 2x mode if it’s not already? or picking a game that explicitly lets you set progressive mode and seeing if that changes anything?


    I’ve got my PS2 set to YPbPr, not RGB. Sorry – that was a typo in my post.

    I found out what likely has something to do with the issue. When using setting my OSSC for 2x-BOB or PASSTHRU for 480i input (3x-LACED isn’t compatible for me), the problem goes away. Which is weird because I swear I’ve checked this already. Up until now my OSSC has been set to 4x-BOB for 480i input. While my TV doesn’t officially recognize the input as 960p (when pressing info it doesn’t mention the resolution), it displays it fine, so I figured it was working how it was supposed to.

    So it seems the problem is my TV is mishandling the 960p input in some way, which isn’t surprising. While it’s a little disappointing to have to use 480p on a PS2 through the OSSC, I’m fine with it, since 240p sources are really what I got it for (which display GREAT in 5x mode btw). It would be great if I could get the colors on 4x-BOB working correctly, but it’s probably not possible.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.