PAL Mega Drive 2 intense flickering

NewHome Forums OSSC, OSSC Pro and DExx-vd isl OSSC – Discussion and support PAL Mega Drive 2 intense flickering

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #22807
    bmp02
    Participant

    Hi all,
    Have just purchased an OSSC for my Mega Drive 2, but can’t seem to get it to work well.
    My setup is a Sega Mega Drive 2, PAL MK-1631-50, no mods. The SCART goes directly into my OSSC, which goes directly into my tv’s HDMI input.

    Have tried multiple games and am experiencing some intense vertical flickering, a little vertical jitter as well.
    Some video footage (don’t mind the bad quality): https://1drv.ms/v/s!AjrKnHr0Vh7GgYlCxWa_6h129oXw-A

    When plugging my SCART directly into my tv, image is fine (full image jumps from left to right every half a second though, which is why I bought the OSSC). Also when putting the OSSC in passthru mode, image is fine. So I assume the SCART cable is not the problem.
    When switching to Line2x mode, the problems start.

    I have read that “Certain models of Megadrive seem prone to picture wobble/sync instability”, but also that the effects are “VERY minimal”, so it doesn’t seem anything like my case.

    Info I’m getting from the screen:
    AV1: RGBS 313p
    15.55kHz 49.69Hz
    VMod: 288p
    LC: 313 VSM: 0

    At this point I think I’ve tried changing pretty much all settings I could find, and I don’t have any clue how to make this work.
    Anyone who can help me out?

    Many thanks.

    #22809
    BuckoA51
    Keymaster

    did you try changing the pre/post coast option to 3 each?

    #22810
    bmp02
    Participant

    Thanks for your reply. Yes, have tested, makes no difference unfortunately.

    If anyone knows what might cause this, or if this is possibly fixed by some settings, please let me know.
    Personally I have no idea (I’m a n00b in this area) so in the mean time I’ll try to rule out both the tv and console this week by testing on another tv and with a friend’s console.

    Another question. So I understand my Sega is outputting a 313p signal being modified to 288p? If this is the case, is there any way to strip (instead of mask) the unwanted overscan area so I can have the full gameplay 240p image across my screen, instead of having to deal with black or colored bars on top and bottom?

    Thank you.

    #22814
    Harrumph
    Participant

    You can change v.active to 240 in advanced sampling options.

    #22818
    bmp02
    Participant

    Have just checked that. It works, but effectively adds black bars to top and bottom of my screen which is similar to just masking it.

    What I mean is: If the Sega’s 313p signal is being output as 288p, isn’t it possible to have it output as 240p instead? So I will have the full 240p game image across the height of my screen, instead of having black bars on top and bottom of my screen?

    #22825
    Harrumph
    Participant

    What I described above will never result in “proper” 240p as the term generally refers to a ~60Hz, ~262-263 line image. It will just change what is defined as the active window.

    Most, if not all, MD games are not 240 vertical lines, they are 224 lines. So you can try v.active 224 also.

    Although, from your description of changing to v.active 240, it seems like your display ignores this change. Possibly because you are in x2 mode, try the higher line modes and/or set your TV to PC mode. This is all up to how compatible your TV is and how flexible it handles scaling.

    #22826
    bmp02
    Participant

    [EDIT- Lots of testing today made this post useless, reply based on today’s outcome below]

    So apparently it’s my tv causing all the flickering in Line2x mode. Using my own console, my own game and all of my own cables on my friend’s tv resulted in a perfect image.
    Are there any settings in OSSC (cause there are none in my tv) that could possibly solve this? Or could Line3/4/5x mode (after some tweaking, if I can get it to work at all) be a solution? Or would buying a new tv really be the only option left for a good image?

    .
    Thanks for your reply Harrumph! I don’t think I fully understand the matter still however.
    On my friend’s tv I noticed the OSSC outputs a 2×288=576p image, resulting in mentioned bars on top and bottom. Is there a way to force OSSC to output a multiplication of 240p instead of 288p? Cause if I remember correctly, after changing the v.active setting, it was still outputting 2x288p according to the info displayed on the tv (I’m not 100% sure though..)
    If a 240p multiplication could be forced, those annoying bars would be gone and I’d have the full beauty of the game displayed across my tv vertically, right?

    Thanks ๐Ÿ™‚

    #22846
    bmp02
    Participant

    Have just spent another hour or two updating firmware, trying to make Line3/4/5x modes work, only trying to get a stable image. But I feel I have ran out of options now.

    Anyone who can help me out?

    In the tv compatibility thread, I’ve read that รกll tv’s are expected to support Line2x Mode, and only 3 reports of problems (and those are with SNES).
    I can hardly believe I’m “lucky” enough to be the owner of the first and only tv to not support Line2x Mode? ๐Ÿ˜ I own a nearly 10 year old LG, 32LC52…..

    #22864
    BuckoA51
    Keymaster

    That would indeed be unfortunate. Perhaps you would have better luck using an NTSC console?

    #22865
    bmp02
    Participant

    Have none that I can test, don’t know anyone with an NTSC console around.

    Have just thought about one last thing to test, don’t know if it makes sense:
    Have tested all of my equipment on a friend’s tv, and it was fine, so concluded the tv is the problem. But thinking about it now, technically I guess that it could still be possible that my console outputs a messy signal, which my friend’s tv handles well, but mine doesn’t. So as a final test I’ll hook up his console to my tv tonight and see what that does.


    @BuckoA51
    Seeing the number of created replies on your profile, I’m assuming you know your shit ๐Ÿ™‚ And reading your reply, am I assuming correctly that you don’t think there’s anything setting related that can solve this?
    Thank you.

    #22870
    Harrumph
    Participant

    I think what is the case is your TV identifies the input based on the total lines rather than the active lines. There are many examples of people not achieving any difference in result on their display after changing either v.active or h.active. So your TV sees 626 incoming lines, deduces it’s 576p video, and determines the output should be 576 lines tall, no matter what.

    Additionally, the flickering is probably due to the incoming signal being offspec. On-spec 576p is exactly 625 lines, and is exactly 50Hz. Your TV simply has poor tolerance to deviations from this spec.
    Another example is that many displays fails to display linedoubled PAL PS1 or NeoGeo, because they output 314 and 264 lines, so linedoubled they are even further from the specification of 576p and 480p, respectively.

    Bottom line, I would recommend you to get a different TV. Hopefully the compatibility list can be of help to you.

    #22884
    bmp02
    Participant

    @harrumph Thanks for your clear explanation! I thought the active lines where the actual lines outputted, I now understand it works differently.

    I have done that last test I mentioned, with another console on my tv, but still the same problem. So getting another tv will be the only solution.
    I’ll check the compatibility list. Make sure to put mine on that proud #1 spot of tv’s incompatable with line doubling ๐Ÿ˜‰

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.