PAL Saturn Image problems

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #44467
    The_Ox
    Participant

    Hi all,

    Apologises if this is a really easy question but I’m having trouble with some games on my Saturn. My setup is a PAL Saturn (v.1, unmodified) going through a Retro Gaming Cables sync over Luma “Packapunch” RGB SCART cable in to an OSSC (unsure of the firmware but it’s fairly recent). This is plugged in to an LG 55OLED-E6. I think I’m just using the generic profile within OSSC (I don’t recall changing this).

    The problem is that, for some games (e.g. I was attempting to play Clockwork Knight 2), the screen simply goes blank sometimes for a reasonable amount of time. Initially I thought it was a sync issue but I assume that the SCART cable I now have should be fine therefore I’m assuming it’s some kind of incompatibility with either my TV and the OSSC or some odd OSSC setting. Occasionally, the OSSC OSD comes up showing the frequency etc. (313p, 49.something Hz) so I’m assuming that the OSSC is struggling somewhere due to some oddities coming from the Saturn but I’m like completely wrong…

    Can anyone help please?

    Dave

    #44497
    BuckoA51
    Keymaster

    does the blanking occur at the same part in the game every time, or randomly?

    #44499
    The_Ox
    Participant

    It seems to be fairly random as far as I can tell.

    #44546
    Furyofury
    Participant

    Are you talking about the black frame (resolution change in a game)? if that’s it that’s normal

    #44595
    The_Ox
    Participant

    No – it is happening in the middle of a game. I don’t think there is any spot where resolutions are changing and this isn’t a very quick black frame. This is just the TV going completely black for seconds at a time.

    #44603
    marqs
    Participant

    Try setting “Analog sync LPF” to 2.5MHz (default value) and “Analog STC LPF” to 0.5MHz (SDTV). If that doesn’t help, you can try adjusting “Analog sync Vth” and increasing “Hsync tolerance”. If none of these help either, as a last resort you can try freeze ADC mode polling/update by e.g. leaving it on profile select prompt – press profile load hotkey, but don’t select one.

    #44675
    The_Ox
    Participant

    Awesome – thank you. That seems to have done the trick. 🙂

    #44687
    marqs
    Participant

    Did you test which one of those suggestions was the key? The information might be helpful in this case as well.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.