PSP help for a total noob

Viewing 15 posts - 1 through 15 (of 31 total)
  • Author
  • #40576

    Ok so i do not know what I am doing when it comes to advanced settings on the OSSC whatsoever. I only ever had it set up to automatically do line 2x, 3x, or 4x depending on the signal. Now i read that there is a feature in update 0.86 that has a psp optimised mode. I read how to set the OSSC to it and i get no picture whatsoever. Can anyone help me figure out what i am doing because i am not used to this.


    It’s possible that your TV doesn’t support it. On my LG I have to switch PSP mode off and on several times before I get a picture sometimes. I have no idea why.


    What kind of TV do you have? Have you tried with both passthrough and line2x mode?

    You should also try cutting off the top+bottom pixel from the image in line2x to produce a standard 540p resolution. The default (in line2x) is 960×544, which is non-standard and some TVs may not like (passthrough mode of 480×272 is also non-standard). This wiki article covers how to do this, but tl; dr: with the PSP mode enabled and set to line2x, in the advanced settings change

    V. Active 270
    V. Backporch 135

    Also if you have a different source for a 540p image, you should test your TV with that source to see if your TV supports 540p at all.

    If that doesn’t fix it, and your TV does support “normal” 540p signals, then it’s possible that your TV doesn’t like the very large offscreen regions of the image (much larger than usual), which isn’t something that can be fixed with the OSSC.


    I have a sony 4k bravia tv, and i have tried both passthrough and line 2x mode. I have nothing else that outputs a 540 resolution so i would not be able to test that specifically, but i can attempt those settings when i am next at home. (Work schedules suck) ive never messed with the backporch or anything but i know how to get in to those menus at least.


    Also i should mention i am using a psp 3000 set to progressive mode. I am using this mainly to test before investing in a dock for my psp go


    Sadly changing those settings does not seem to work. My tv thinks it is getting a 480p signal but i just have a black screen


    Maybe i am just out of luck? Im tempted to try a different tv but my entire setup is centered around a single tv. Maybe i should just use my vita tv for psp games, but i was hoping to avoid that if possible.


    You’re not out of luck quite yet, we’ve just got to put back some of the letterbox.

    Start by using the advanced settings to restore the originally intended image — letterbox and everything. Make sure you’re doing this with the PSP sampling mode enabled and with line2x turned on (although if it doesn’t work, try with line2x turned off). Here’s how you do that:

    H. Refresh 858
    H. Active 720
    H. Sync 62
    H. Backporch 60
    V. Refresh 525
    V. Active 480
    V. Sync 6
    V. Backporch 9

    In passthrough mode, this should give you the originally intended letterboxed 480p image. In line2x, it’s 1440×960, in passthrough it’s 720×480.

    Now start to remove the letterbox by decreasing H/V Active. If your TV doesn’t drop sync, you’ll see the image growing larger, but also moving away from center of the screen. To re-center it, increase H/V Backporch until centered. Keep decreasing it until your TV loses sync. Whatever value you end up with (as defined by HxV) is the minimum resolution (aka most zoomed in) that your TV can support given the PSP’s true 858×525 input resolution (but see the next paragraph).

    It’s also possible (likely, in fact) that your TV supports discrete resolutions around standardized values (e.g. 480p, 720p, etc.), but not the weird ones in between. So there’s one more resolution to try, you can cut the line2x 1440×960 image down to a 720p image. The 16:9 720p resolution is 1280×720, so to get that, get back to the default settings for the PSP I mentioned above, make sure you’re in line2x, and use the following:

    H. Active 640
    V. Active 360
    Adjust H/V. Backporch to re-center


    How low should i be able to go? I got my h active down to 480 and could go lower but my v active loses sync at anything lower than 424


    In 2x mode anyway, in 1x mode i can go lower


    Sync drops if i go below v 322 in 1x mode


    Also i dont see a way to adjust v refresh? Maybe im reading the menus wrong.


    I tried the 640×360 setting and my tv only syncs in 1x mode. In 2x mode i get no picture


    Sorry, ignore the part about setting V. Refresh. That’s automatically detected by the OSSC.

    In line1x mode with a V. Active of 322, there’s (525-322=) 203 lines offscreen.
    In line2x mode with a V. Active of 424, there’s ((525-424)*2=) 202 lines offscreen. Because this is line2x, we can’t test with exactly 203 lines offscreen.

    It sounds like your TV supports a maximum of 203 lines offscreen.

    Building on that, in line1x mode if we can’t go below 322, then the aspect-ratio-preserving setting you should use for H. Active is (720/480=x/322; x=) 483, which is a resolution of 483×322. For line2x, we can’t go below 424, so that puts the H. Active at (720/480=x/424; x=) 636, which is (636*2×424*2=) 1272×848. Of those two (line1x and line2x), 1272×848 is ((1272*848)/(483*322)=) 6.9x more pixels than 483×322, while the actual image is only 4x more pixels (2x in both dimensions), meaning that line1x should produce the most “zoomed in” picture, but it’s probably going to be less sharp than line2x because your TV is doing more of the upscaling.

    Also, neither of these resolutions divide well into 3840×2160 (4k). So let’s figure out what the nearest resolutions are that let the TV integer multiply up to fit the screen.

    For line1x, the next nearest integer above 322 which when multiplied by a whole integer produces 2160 is (2160/6=) 360, and preserving the aspect ratio that’s (3840/6=) 640. That’s a 640×360 resolution, and you can get that by setting H. Active to 640 and V. Active to 360.
    For line2x, the next nearest integer above (424*2=) 848 which when multiplied by a whole integer produces 2160 is (2160/2=) 1080, and preserving the aspect ratio that’s (3840/2=) 1920. That’s a 1920×1080 resolution (aka 1080p). Unfortunately, line2x does not produce enough total lines or pixels to get to 1080p, neither horizontally nor vertically. Including all of the offscreen signaling (some of which is actually needed), line2x is 1716×1050. So an integer division of 4k in line2x mode isn’t possible for you.

    So your options are:
    1. Most zoomed in – 483×322
    2. Most sharp(?) – 1272×848
    3. Even multiplier to get to 4k (might be more sharp than option 2) – 640×360


    Whoops, did those first two options’ aspect ratios incorrectly. I calculated against the 720×480 (4:3) resolution, when the TV’s aspect ratio is actually 16:9. Redoing that math.

    1. line1x – 576×324
    2. line2x – 768×432
    3. line1x integer multiple to 4k – 640×360
    4. line2x integer multiple to 4k – still impossible

    With that aspect ratio, line2x (option 2) is actually going to be the most zoomed in because there’s 1.77x more pixels in the overall frame but 4x more active pixels. So line2x may be your best choice overall.

    So in line2x mode, that’s
    V. Active 432
    H. Active 768

Viewing 15 posts - 1 through 15 (of 31 total)
  • You must be logged in to reply to this topic.