Remote not working after firmware update

NewHome Forums OSSC & OSSC Pro OSSC – Discussion and support Remote not working after firmware update

Tagged: , ,

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #27340
    milkybar1983
    Participant

    Just got a new OSSC from ebay and first thing I did was update the firmware, all went OK but the remote won’t work after reboot. The unit still works and the hardware buttons still work. Also the LED flashes when you press buttons on the remote so its recieving a signal. None of the buttons actually do anything though ie. menu

    According to the ebay seller the remote has to be ‘re-learned’ any ideas?

    #27344
    James-F
    Participant

    ebay seller?
    This support forum is for OSSC bought from VGP only.

    Try to press the “TV” button on the top left of the remote.
    If that fails read here:
    http://junkerhq.net/xrgb/index.php?title=OSSC#Remote_control_setup

    #39660
    fwaggle
    Participant

    I’m going to grave-dig here because it’s the first hit on Google/DDG for this exact problem, as it’s been so long since I updated firmware that this tripped me up *again*, and I screwed it up in exactly the same way twice.

    Specifically, with the link above, I have a Harmony remote so I went through that whole ordeal (including Logitech’s terrible software) unnecessarily when this is the only bit you care about:

    Now, power cycle the OSSC while holding BTN1 on the OSSC’s PCB. A target function name (e.g. “MENU”) will then be displayed on the OSCC’s LCD screen. Press the corresponding key on the remote control, if the OSSC receives the code correctly you will be prompted to confirm the new code. Press the same key again to confirm, or BTN0 on the OSSC’s PCB to go to the previous key. If you press BTN0 when configuring the first key, the default keymaps will be loaded.

    Once all remote control keys/buttons are programmed, the new keymap will be saved and the OSSC will return to normal operation.

    That is, updating the firmware wipes the settings, which includes the keymap for the remote, you just have to reconfigure them again and you’re good to go. Don’t panic!

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.