RetroTink 2X-Pro Multiformat Firmware update issues

NewHome Forums RetroTink Products RetroTink 2X-Pro Multiformat Firmware update issues

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #43939
    crivett95
    Participant

    Hi,

    I’ve been trying to update my RetroTink 2X-Pro Multiformat to the latest 1.7 firmware but every time I try, I receive a “System.IndexOutOfRangeException” from the RetroTink Firmware Tool. I’ve tried multiple Windows 10 and 7 based computers which all produce the same results. Has anyone else had this problem and found a solution?

    Thanks

    #44331
    BuckoA51
    Keymaster

    We’re actually expecting one of these units with this fault back with us soon, so I’ll try it on my PC and see what happens.

    #44481
    beatwiz
    Participant

    Hey guys!
    Having the same problem (System.IndexOutOfRangeException). Any hints? 🙂
    Thanks in advance!

    #44513
    beatwiz
    Participant

    K… So I did this before but I guess I forgot to double check all the steps this time.

    This error happens when you dont put the device in flash mode. So as per the manual instructions:

    “4. Plug your device into your computer’s USB port while holding down the ‘INPUT’ button. The LED should be RED indicating update mode.”

    Flashing without issues after this.

    Sorry about that and I hope this helps.

    #45085
    BuckoA51
    Keymaster

    Yeah, be careful to hold down the correct button, not “Filter” like I was doing the other day!

    #45121
    crivett95
    Participant

    I’ve just tried again now. Was definitely holding down the right button and the device lights up red as expected. Unfortunately I still get the error on multiple computers.

    Any other ideas?

    #45154
    hugox64
    Participant

    Maybe try a different micro USB cable? I initially had a problem updating my firmware because the firmware updating tool wasn’t recognising my 2xPro-M. But after swapping out the cable it worked. I can’t remember having your specific error message though…

    #48368
    Virtualboi92
    Participant

    Hey there, I’m having the same issue with a newly purchased 2X PRO-M. Has a workaround ever been established for this?

    #48369
    BuckoA51
    Keymaster

    Be sure to follow the instructions carefully and make sure you’re not holding down the wrong button on the unit. If that still doesn’t work, we’ll arrange an RMA.

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.