RetroTink doesn't work with A/V switcher

NewHome Forums RetroTink 2 Products RetroTink doesn't work with A/V switcher

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #26248
    TiredKorok
    Participant

    Hello,

    I was hoping to get some ideas about what to do for my problem.

    I am currently using this auto sensing a/v switcher to switch to whatever console I currently have turned on: https://usermanual.wiki/Radio-Shack/RadioShack151985UsersManual352677.1484721781.pdf
    It’s great, works fast, and I haven’t had issues with it before with my other hdmi scaler.

    However, it won’t work with the retro-tink. Whenever I hook up the s-video out to the retro-tink the screen will go black and every once in a while an image will flash on screen. While it’s doing this the input mode selector on the retro-tink will flash through the options.

    I was thinking maybe getting a signal booster might help?
    I found this cheap signal booster on amazon: https://www.amazon.com/gp/product/B000PAM076/ref=ox_sc_act_title_1?smid=A6YHF9ZZJU41C&psc=1
    I don’t mind buying it just to try it but I am worried that it could damage my retro-tink. It boosts the signal by a 2db gain.

    Any help or advice would be appreciated, thanks!

    #26322
    BambooShadow
    Participant

    While it’s doing this the input mode selector on the retro-tink will flash through the options.

    I always get that behaviour, when my Display/Monitor is turned off –>once I turn on my monitor, it works.

    Since your splitter/switcher is powered, I don’t think the signal booster should make a difference. Dunno whether it can hurt the RetroTINK-2X.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.