RetroTink Multi Issue: Mega Drive Component Issues

NewHome Forums RetroTink Products RetroTink Multi Issue: Mega Drive Component Issues

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #45190
    Mister
    Participant

    I’ve got a RetroTink Pro Multi-Format, and with one noticeable exception, it’s been absolutely fantastic. However, when I try to use it with my Mega Drive, I run into a strange issue: I can either get audio OR video, but never both at the same time. If I remove the green Y line from the RetroTink, I get stereo audio coming from the headphone jack on the Model 1 Mega Drive; if I plug the Y line in, the audio disappears and I get beautiful video.

    My TV does not have component inputs, but I tried plugging the Y line into the composite input together with the R/W stereo connectors and got a grayscale picture with perfect audio, leading me to believe that the issue has something to do with the RetroTink.

    Does anyone have any idea why this might be happening?

    For reference, I’m using a Mega Everdrive Pro, Japanese Model 1 Mega Drive, and the RetroGamingCables component cables: https://www.retrogamingcables.co.uk/sega/mega-drive-1/Sega-Mega-Drive-1-Genesis-1-Stereo1-Component-YPbPr-cable-240p

    #45298
    BuckoA51
    Keymaster

    That is a bizarre one, can you try a different display just to rule that out?

    #45347
    Mister
    Participant

    So, I have a separate LG computer monitor (LG 22en43 V–B) with a headphone jack that supports audio over HDMI. I gave that one a try just now, and with THAT display, I CAN get both video and audio (via headphones plugged into the back of the display) at the same time. Any idea why changing the display would have an effect on this?

    My TV is this old model from, like, 2013: A SHARP LCD TV AQUOS H11.

    (For what it’s worth, the Mega Drive is the only console that is giving me this issue. All other consoles running through component work just fine.)

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.