Sega Genesis Issues

Tagged: 

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #21879
    yavin88
    Participant

    I am a new OSSC owner, I have a 1.6 with 0.81 aud updated. I have a NTSC sega genesis model 2, using a Retro Gaming Cable’s Packapunch cable (csync).

    When I got the OSSC a week or so ago tested it with the genesis, everything worked fine. Shortly after I got a cable for my PS2, tested that and it also worked fine and is still working. Problem is the genesis now no longer seems to be working, I just get a black screen. The TV seems to get the right signal but nothing gets through. Any suggestion on how I can troubleshoot this?

    The genesis is clean as a whistle and doesn’t show any signs it is malfunctioning and the OSSC registers it is getting a signal when the genesis turns on. Not sure what the issue is, because it worked before.

    #21882
    AtlasShrugged80
    Participant

    Are you using 2X or higher for 240P?

    #21887
    yavin88
    Participant

    Yes I have tried line doubling, tripling, quadrupling, ect. All The formats my TV can accept.

    #21888
    NoAffinity
    Participant

    Did you change settings to get it to work with (or looking better with) the PS2? It’s possible when changing settings, you have now made the output from the genesis incompatible with the TV.

    If you’ve got things looking good with the PS2, I suggest saving that as a profile. The go to Settings Opt -> Reset Settings.

    Now you can test, and see if you’re back in business at default settings.

    If you want to take it further from there, then use FBX’s optimizations to dial in the OSSC for the Genesis: http://www.firebrandx.com/osscprofiles.html

    Assuming (hopefully) that gets you back in business and even looking better than before, then save that as a profile (or one for 352 line games and one for 320 line games).

    #21890
    Galdelico
    Participant

    Very dumb call, apologies in advance should you have checked that out already: since everything seems to work fine, and you just get a black screen, any chance you’re on the wrong AV input channel (see the remote numpad below)?

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.