Sega Genesis vertical lines

NewHome Forums OSSC & OSSC Pro OSSC – Discussion and support Sega Genesis vertical lines

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #21538
    SegaFanboy
    Participant

    Hi,
    So last week I moved my Genesis to my OSSC setup and somehow it doesn’t look good. It’s a model 1 and on the OSSC there are bright vertical lines on the whole picture.
    I made some pics comparing the OSSC to the Framemeister. Same setup, same cables, same TV, same Console.

    OSSC:
    OSSC

    Framemeister:
    Framemeister

    I tried my old Megadrive and it had the same issues. Both work fine with the Framemeister or when I put them directly into the TV. I think the lines are some interference from the consoles themselves, but somehow the OSSC just makes it worse, while my TV or the Framemeister cleans them up.

    Is there a setting what may help me? I tried to adjust the Low-pass Filter but the Lines just change position.

    #21556
    noodohs
    Participant

    Leave the video LPF on auto if it isn’t already. For 240p sources like SNES, that will set it to it’s lowest setting. I get those same horrible bars unless it’s on that setting, so it really is essential.

    Edit: Sorry, thought this was about the SNES for some reason. But it still applies here. Genesis is also generally more prone to jailbars, so they may not disappear completely.

    #21558
    Anonymous
    Inactive

    you can bypass the native RGB amp, and replace with a THS7314, to potentially fix the jailbars. I’ve never done it, don’t know how well it works. The biggest take-away from below is the only potential difference from this mod is eliminating the jail bars.

    Genesis RGB Bypass

    #21559
    BuckoA51
    Keymaster

    The brightness on the OSSC image looks a lot higher too, what SCART cable are you using?

    #21564
    SegaFanboy
    Participant

    Thanks for the answers. The cable is from retrogamingcables.co.uk, but it wasn’t the problem. Today I tried some settings and somehow noticed, that changing the TX-mode to DVI fixed the black. I also noticed, that this mode somehow greys out many settings on my Samsung TV, the most noticable was the “HDMI Black Level” setting. So I changed TX-Mode back to HDMI and set the HDMI-Black Level on my TV to low – And the lines where gone.

    When using the Framemeister, it is the same as when using the OSSC with DVI-Mode – this setting is greyed out.

    Can somebody explain this to me?

    #21571
    GameJon
    Participant

    Alright this is going to be long-winded because I’m drunk… Sorry.

    From what I understand the OSSC outputs full range RGB, so HDMI black level being on “high” (or “normal” for Samsung TVs) “should” be correct… Otherwise you’re at risk of crushing (losing) detail at the extremes of the dark/light areas. What you’re seeing on that image is the Megadrive’s jailbars being exaggerated because the brightness is set too high.

    I could be getting too technical here, but basically imagine that you have a source outputting the same test pattern that you see when you turn on the OSSC – a single image with a gradient going from white to black. A full range RGB signal will have 256 (0-255) steps between the whitest part of the gradient and the blackest part. A limited range RGB signal will have 220 (16-235) steps between the same white/black parts.

    You have to tell the TV what sort of RGB range it should be expecting so it knows to map the correct values to the correct brightness range on the panel… If the TV HDMI black level is set to “low” then it expects a value of 16 and below to be completely black and outputs to the TV accordingly, the same goes for the high end and white. If it’s receiving a full range signal (while set to think it’s limited) then it’s culling information, and you’ll get an image that seems extremely vibrant/high-contrast but at the expense of any information that’s in those dark/light areas. This is why you’ve stopped seeing the lines in your second image, it’s culling info in the dark areas.

    High (normal) black level = expects a full range (0-255) RGB signal
    Low black level = expects a limited range (16-235) RGB signal.

    The reason this setting exists is because traditionally TVs (broadcast TV etc) have always worked within a limited range, whereas PC monitors have always been full range. The HDMI black level option is there to allow your TV to correctly map PC-esque full range sources (like the OSSC) that don’t have an option to change to limited range. Hell, even modern consoles output limited range by default.

    Problem is, analogue sources (especially consoles) don’t exactly adhere to a 0-255 level in the same way that digital sources do. On most Samsung TVs “45” should be the neutral brightness setting, where black is actually black (and not a slight shade of grey) without losing information in the dark areas, but with some consoles connected to the OSSC you’ll probably need to set the brightness down a couple of notches to compensate – mine’s around 42/43. This used to be the same on TVs when it came to the contrast setting, set it too high and you start to lose detail in the white areas – however, nowadays most TVs can have the contrast set to full/100 and not cull any information.

    It’s just a guess – but Samsung TVs usually save different profiles (per source) depending on what’s connected. If something’s in HDMI mode (and adheres to certain resolutions/refresh rates) then the TV sees it as a standard input, you can choose to turn on game mode, change colour temperature, adjust zoom/resize options etc… If it’s in DVI mode then it probably sees it as a PC input, which disables a LOT of processing options – including game mode. You’ll also probably find that HDMI black level being greyed out also means it’s on “normal” (high) because it’s expecting a PC input.

    The TV will have different settings saved/applied when it switches between normal/game mode and PC mode (brightness/contrast/any dynamic crap that’s turned on) and it’s likely one of those settings that’s blowing out the contrast, not HDMI black level. I know this because the 61Hz I get out of the RGB modded PAL N64 (running NTSC software) forces the TV into PC mode, disabling colour options etc – and loading different settings to the ones that pop up when it’s in game mode.

    Long story short – while many of your TVs options may vary, turn on game mode, put HDMI black level on “high”, brightness on “43”, contrast on “95”, sharpness on “0” (unless it’s in PC mode, at which point it’s probably between 25-50 – thanks Samsung), colour between 50-55 (and temperature on warm1), colour space on “native” and turn off any of the stuff like dynamic colour/contrast/clear motion/clean view/film mode and all that crap…

    As for why it looks OK with the Framemeister? God knows – maybe it’s mapping colours in a different way?

    #21573
    SegaFanboy
    Participant

    Wow, thank you so much for this post. I feel so dumb now, all the years and I didn’t really recognice that my brightness was way too high. It was on 50 (default) and I never really cared of this setting. I always thought 50 was neutral, but like you said it’s 45. Now I have really black bars on the side and not greyish ones and EVERYTHING looks better.

    Now I also understand the black Level setting. I changed it back to normal (I just have normal and low). I looked at the test pattern and saw what this setting does, it really destroys the blacktones.

    So, I have just another dumb question, since my Genesis seems to be really bright and I need to turn the brightness down to 40, which is too dark on all other consoles. Isn’t it better to adjust R/Pr / G/Y / B/Pb offset and keep the TV at 45? If I set them all to 122 all black Jailbars are gone and I can keep the TV at 45. Or do I loose information if I do this?

    #21581
    GameJon
    Participant

    Wow – sorry for the wall of text last night!

    since my Genesis seems to be really bright and I need to turn the brightness down to 40, which is too dark on all other consoles. Isn’t it better to adjust R/Pr / G/Y / B/Pb offset and keep the TV at 45

    Yeah that sounds like a good plan – don’t think it’ll cull information, and the Genesis doesn’t have a massive range of colours/tones anyway – you could always use 240p test suite (if you have an everdrive or cheap flashcart) to make sure everything looks OK with the new settings. Also easier to save those settings to a specific OSSC profile rather than having to change brightness on the TV every time! 🙂

    #21582
    SegaFanboy
    Participant

    Your “wall of text” helped me a lot and saved my weekend 🙂

    #21863
    AtlasShrugged80
    Participant

    GameJon – That “wall of text” helped me as well because I had a question about black level. Will the OSSC always output full range (0-255) regardless of the console attached? For instance, I have a Sega Saturn attached (via RGB SCART) and my Samsung TV has the traditional Low, Normal, and Auto settings. It appears that “Auto” is setting it at “Low” (no difference between the two). But, based on your post, it sounds like I should be at “Normal,” right?

    #21870
    SegaFanboy
    Participant

    It should be on normal. Just look at the OSSC test pattern and switch between “normal” and “low”.

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.