SNES 5x Pixel Sharpness Help

NewHome Forums OSSC & OSSC Pro OSSC – Discussion and support SNES 5x Pixel Sharpness Help

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #20768
    EVILSANTA777
    Participant

    Hey all, new to the forums and very glad to have my new OSSC. I’m pleasantly surprised that every mode from 2-5x works and has no sync issues at all on my TV, but something seems off about the picture, as far as pixels go, to me and could use some help.

    For set up I’m using an older TV, a 59 inch Samsung Plasma PN59D7000FF. I’m using a 1CHIP-01 SNES with an RBG SCART cable from Retro Access, plugged directly into the OSSC then plugged into an HDMI switcher, then into my TV. I’ve tried taking out the HDMI switch and going direct OSSC -> TV just for troubleshooting but the image seems pretty much identical.

    I’ll link some pictures here to what I’m talking about, but it seems like the pixels are much too sharp/and or blurred. Something just seems off to me, and I don’t quite know how to correct it. Is there a setting to fix this, and make the pixels look smoother? I’m running pretty much all default OSSC settings, except for output is 256×240 for line 5x, and the Video LPF is at 9mhz if that matters. I just know this looks nothing like so many of the beautiful OSSC comparison videos I’ve seen lol mine looks too blocky. The pictures are regular 2x mode in 4:3, and then 5x mode and a close up within 5x mode. Another small thing, is the OSSC capable of filling the entire screen in 5x mode? Can’t seem to get it to fill the entire TV no matter what setting I fix, and my TV is in 16:9 mode. Thanks for any help!

    OSSC 2X (http://www.mediafire.com/file/25l9hal55htccf3/ossc_2x.jpg)
    OSSC 5x (http://www.mediafire.com/file/hygb697x226hf6w/ossc_5x.jpg)
    OSSC 5x Close Up (http://www.mediafire.com/file/v1uzl6pxldtiy3l/ossc_5x_closeup.jpg)

    #20776
    Harrumph
    Participant

    Your tv seems to over-sharpen the image. Reduce processing as much as possible on your TV.

    In x5, the picture should already fill the screen completely (in fact a few lines are cropped from the standard 224 line snes output). Maybe your tv is doing something funky with the scaling also? Try using 1:1 mode or similar.

    #20780
    EVILSANTA777
    Participant

    Hmm I tried turning off as many of the options under pictures as I could within the TV’s settings and even flipped game mode on/off but seems to have no effect on the sharpness. Is this something where it may be impossible to get the TV to not process the picture? Because that would really suck considering I found a TV that takes every line mode for the SNES. Most of the options available to me are things like brightness, contrast, gamma, sharpness and they are usually set between 50-100. Should I try turning them all to zero? I’ve already turned off everything else such as black level mode and some other odd settings that I could find.

    As far as the screen, no it oddly leaves two huge bars on the sides of the picture. I believe it may be the TV being odd with scaling as well, because it’s in 16:9 mode. If I try switching to “wide fit” on the TV it super stretches the image to get it to fill, but it would require me to zoom way out using the OSSC and reduce the quality even more. Other than that wide fit option none of the other screen settings seem to get it to fill the screen. Man this is going to be super disappointing if the TV accepts the line modes but still won’t work.

    #20781
    EVILSANTA777
    Participant

    So slight update, I’ve tweaked every setting I possibly can on both my TV and OSSC to no avail, still can’t fill the screen and still can’t get the pixels to not look so blocky. I suppose I’ll leave that for now, until someone happens to know if I’m simply out of luck on making my TV not process. Game mode seems to help the slightest amount but not much. I can try another TV tomorrow to see if the same issues persist.

    But, I also was able to plug the OSSC directly into my PC monitor rather than my TV with the same set up as before and still got an image that seemed slightly off, mostly with the screen fill. So perhaps it is still partially the OSSC? The monitor definitely cleaned up the majority of the issues that were on the TV but I’ve been looking at pixels all day and can’t tell if it’s how it should look or not lol, I’ll link images below. Even on the PC monitor the same exact black bars were on the sides and I couldn’t find any way to get the OSSC to allow it to fill the whole screen in 5x mode, or actually any mode. It seems like 2x auto fills the screen, but the other line modes have varying amounts of the screen consisting of black bars on the left & right. Any help would be great, I’ve been looking forward to this OSSC for awhile now and I’m a little disappointed that my basic SVideo -> HDMI upscaler on the same TV treats the pixels and screensize better for the time being. My only other thought is maybe the SCART cable? But it’s a high quality cable and was bought from Retro Access who has excellent reviews and ratings, so I assumed that’s not the problem. Thanks for any insight or help!

    OSSC 5x PC (http://www.mediafire.com/file/w2p9rmtb9b5a8sr/OSSC_5x_PC.jpg)
    OSSC 5x PC Close up (http://www.mediafire.com/file/rh5ffkepefy6kf3/OSSC_5X_PC_Closeup.jpg)

    #20786
    Harrumph
    Participant

    Of course, it’s a 4:3 image so black pillars are normal. If you want to stretch that to widescreen, that’s insanity, blasphemy… ;-P

    #20790
    paulb_nl
    Participant

    Can you link to a image/video of what you want it to look like? You say you don’t want it so blocky but you are using line5x 256×240 which is the sharpest mode there is.

    If you set lineX5 to 1600×1200 your TV might stretch it to 16:9 but if you want smooth pixels you should be using 240p passthrough/linex2 generic 4:3 and find some way to remove the processing of your TV.

    #20796
    EVILSANTA777
    Participant

    Sure thing, for comparison to the pictures in my original post, this video is someone running DKC2 on 5x on an 65″ LG TV (https://www.youtube.com/watch?v=E07sr3Zyba8), it looks almost identical to my PC Monitor so if I could get that image I’d be very happy. Haha I understand the blasphemy of trying to widescreen it, I just thought it’d be nice if I could do it without the image being stretched too much. Really my main goal here is to make my TV/the OSSC stop processing the pixels the way it does and get closer to that video I linked or even my PC monitor picture. I even tried the 240P Pass-through and 2x and it still looks too sharp on my TV, that first picture I linked to 2x is using those settings you recommended. I’ve tried absolutely every setting I can get my hands on through the TV’s menus, to no avail. Is it possible that I can’t remove more of the processing on the TV?

    #20847
    FBX
    Participant

    Those pictures definitely look like the sharpness of the display itself is turned way up. Make sure that isn’t the case. It’s not that the image is ‘blocky’, but rather you’ve got edge enhancements that are causing the edges of pixels to have ringing artifacts.

    Edit: According to the manual, the TV does have an edge enhancement feature in the advanced settings menu. So of course make sure that’s turned off too.

    #21087
    EVILSANTA777
    Participant

    I actually found that edge enhancement and flipped that off and it still seems a little too sharp, it’s seeming like I may unfortunately just need to deal with it. At least the 5x works I suppose!

    #21088
    NoAffinity
    Participant

    You mentioned in reply #20780 that you have a sharpness setting available. Have you turned that all the way down? I assume you have, but thought it worth asking/focusing in on.

    I’m observing this thread as a matter of personal interest as well as I see some of the same things on my TV, which I couldn’t clearly define why it looked off, and this thread has hit the nail on the head.

    #21089
    EVILSANTA777
    Participant

    Yeah I turned the sharpness setting itself all the way to zero and then back to 100/max and it had almost no noticeable effect at all, let alone didn’t fix the issue entirely. This is why I’m thinking it must be an under-the-hood processing task that my TV is doing that’s unable to be turned off/down.

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.