Trouble playing chrono trigger

NewHome Forums OSSC, OSSC Pro and DExx-vd isl OSSC – Discussion and support Trouble playing chrono trigger

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #36308
    Forral
    Participant

    Hi,
    have recently just got an OSSC and am getting to grips with it but so far am pleased with it. However I have run into an issue with chrono trigger being played on a pal SNES through it. Everything works fine until a text box comes up, at which point the screen will blink off and on a couple of times and then stops receiving a signal, though sometimes it stops immediately rather than blinking. Once it crashes a red light comes on next to the green light which stays on. Other games seem to work fine through it including snes ps2 and psx games, and it happens both on my tv, a sony 49xg81, and my dell pc monitor. Playing chrono trigger without ossc and everything works fine though looks much worse. I have tried updating the firmware and tried firebrandx profiles for the snes but same problem persists.
    Any help anyone can give would be much appreciated as I never got a chance to play this great rpg when a kid and would love to do so through ossc.
    Thanks

    #36310
    nmalinoski
    Participant

    Red LED on the OSSC means it’s no longer receiving sync from the console. If you’re really only having trouble with this one game, I’d start by cleaning both the contacts on the game (if no specific cleaning kit, 91%+ iso and a cotton swab) and the cartridge slot.

    #36326
    Forral
    Participant

    Just to let everyone know I managed to fix this issue by increasing the analog sync vth a bit. Thanks

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.