I messed with settings I shouldn't have on the OSSC. Please Help. I'm a Moron.

NewHome Forums OSSC & OSSC Pro OSSC – Discussion and support I messed with settings I shouldn't have on the OSSC. Please Help. I'm a Moron.

Tagged: ,

Viewing 15 posts - 1 through 15 (of 23 total)
  • Author
    Posts
  • #24019
    Katcher
    Participant

    TL:DR, I’m an utter twat. I fucked up. How can I get the OSSC back to “Factory Defaults” like it was out of the box as using Reset Settings is not working nor is rolling back firmware. I’ve learned my lesson the hard way and know not to touch shit I don’t understand.

    Bought an v1.6 OSSC on Monday and it arrived yesterday. Great piece of kit and worth the £160. So, out of the box with firmware 0.81a I could connect my PS1’s(A modded SCPH-5552 and SCPH-102) via EUROSCART and it worked perfectly, even got rid of the weird wavyness I was experiencing when plugging the SCART straight into an old HDReady TV I had. HUGE thumbs up from me here. I could even get it all outputting at Linex5 without issue and my god was it gorgeous.

    However…

    I then updated to the latest firmware after making sure the OSSC did indeed work, 0.82a. Everything was fine, so I went about exploring the settings and messing with things until I decided to give the Advanced Timings a look…

    Apart from the Horizontal/Vertical Backporch Length settings(which before I fucked up I used to position the output if need be) I realise now I should not have touched anything else. The exact settings I buggered with I can’t remember. Now the wavyness is back making it look as if I’m having an acid trip while playing the PS1, the output settings don’t work like they initially did and toggling each one will drop the image before bringing it back as if those settings altered the image even though initially they didn’t(The only settings I had to worry about with the PS1 when shit worked before I messed up were the 240p/288p proc and 480i/576i proc options), games are now cut off either at the top and bottom or left and right(and not from the user define H/V Masks) when in Linex5 mode, and Linex5 mode sometimes straight out fails to work on my LG Smart TV or my Acer monitor when it did without hassle initially out of the box. Before all this I also tried out the Fat PS2 I have with the same SCART cable and wonder if that might have contributed to my idiocy.

    Resetting the OSSC’s settings doesn’t seem to be fixing this issue either which is rather annoying. I even tried flashing back to 0.81a but nope. Nada.

    Is there a way to completely reset the OSSC so that it’s back to the way it shipped to me or at the very least can I get the defaults for EVERY value so I can manually do it myself or have I irrevocably fucked up and/or discovered a bug?

    #24022
    BuckoA51
    Keymaster

    Do a settings reset, save your profile and then power cycle of OSSC, that should do the trick.

    #24024
    Katcher
    Participant

    Does the OSSC have a profile it loads by default that I should save to? I’ve tried doing what you describe yet no difference unless I’m doing it wrong?

    #24032
    Steo
    Participant

    The OSSC loads the last profile you used before powering it off, so you literally just have to save it to any profile. What Bucko said should be working for you if all you want is default settings.

    #24035
    Katcher
    Participant

    It’s not just default settings I’m after. I just want to get everything back the way it was out of the box before I screwed up and resetting the settings, as I’ve mentioned, isn’t helping. When I got my OSSC, and before I fucked up after flashing it with the latest firmware, I was able to use Line5x mode without image cutoff on both my LG TV(43LH590V) and my ACER monitor(can’t remember model. Gsomethingorother). Now that I have, even if I reset settings to default, it always seems to be cutting off part of the output, even in 1600×200 and 1900×200. Not only that, and I also mentioned this initially, the displayed output on any setting is all wavy(if I had to guess it’s a sync issue?), which it wasn’t before I screwed up. Whatever I have done isn’t being reset when I try resetting settings to default and it’s frustrating the absolute hell out of me trying to fix this. It doesn’t help that I’m utterly shite at trying to explain things either so that I can receive help.

    #24037
    Steo
    Participant

    If you reflash the firmware again, it will go back to the way it was when you flashed it. That’s if it was working for you on 0.82 before changing anything.

    It’s odd that default settings aren’t fixing it for you though.

    Did you happen to change the aspect ratio on the TV itself accidentally? Some TV’s use 16:9 which crops overscan and you can set an option like full or just scan etc.

    #24038
    Katcher
    Participant

    No. The TV is set to “Original”(it’s just an autodetect). But it doesn’t matter whether I use 16:9 or 4:3. I still get cut off. it’s really noticeable on Wipeout 3 SE. Either the top or the bottom of the HUD gets completely cut off

    #24039
    Steo
    Participant

    That’s unusual because once you have 5x set to a mode with 1200 lines, it shouldn’t have anything cut off as long as your TV is picking it up as 1600×1200 or 1920×1200. It should only be getting cut off in 1920×1080.

    Wait, is it a PAL PS1? The wavy thing happens mine sometimes and I have to unplug and replug the SCART lead to fix it.

    If it’s PAL then it’s 1440p in 5x and that explains why it’s cut off. You’d be better off using 4x and using that 1080p tweak I shared for PAL, if it’s NTSC then disregard that part.

    Edit: If it was definitely 5x you were using, then maybe you had on 320×240 optimal instead of generic 4:3.

    #24042
    Katcher
    Participant

    Nah it’s left set to generic 4:3. I need to note, both PAL consoles are modded. SCPH-5552 with a Mayumiv4 and the SCPH-102 with a ONEChip. It can handle both NTSC and PAL games(Not like Parasite Eve is gonna come to the EU any time soon…) That might explain why NTSC games I’ve burned to disc behave better than Wipeout 3 SE. Thank god we don’t have that shit to deal with in modern gaming.

    #24046
    Steo
    Participant

    Yeah true, at least they done away with all this nonsense nowadays.

    Well for NTSC games you can use 1920×1200 or 1600×1200, but for PAL consoles you can use 4x and try this

    That seems to be a good way of getting the entire window on screen for the majority of PAL titles. You will have to force 4:3 though.

    #24048
    Katcher
    Participant

    4:3 is alright with me honestly. I just wanted to try avoid 4x since with doesn’t look great with scanlines compared to 3x and 5x unless there’s a way to make em look better?

    #24051
    Steo
    Participant

    Do they still look worse for you in 4x even when it’s being picked up as 1080p using those settings?

    I can only get 3x on my 4k set and 2x in PAL on it, so I can’t really test the scanlines unless I try my smaller 1080p set to test it.

    #24052
    Katcher
    Participant

    Surprisingly after following your advice the Scanlines look nice and uniform in 4x just like they do in 5x. I need to ask though. Why must the output be forced to 4:3? Right now the OSSC is connected to my ACER monitor that I’ve been testing it with and Wipeout 3 looks fine. Or is forcing 4:3 only necessary for games without widescreen support?

    #24053
    Steo
    Participant

    Yeah it’s just for games that don’t have widescreen so they won’t look stretched. 1080p scales nicely on a 4k set and with V Active on 270 (x4) = 1080. You basically get exactly 1080p output to the display unlike 960p (240 x 4) from NTSC.

    On PAL systems they usually have slight borders even on optimised titles so you aren’t even losing any of your picture.

    #24054
    Katcher
    Participant

    I’m guessing V Active set to 270 would be just as good on a 1080p TV/Monitor? Too poor for a 4K display right now lol.

Viewing 15 posts - 1 through 15 (of 23 total)
  • You must be logged in to reply to this topic.